This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 59115 - XFree86 4.2 segfaults on C&T card
XFree86 4.2 segfaults on C&T card
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-31 03:47 EST by Alan Cox
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-21 17:10:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/XFree86.0.log (12.78 KB, text/plain)
2002-01-31 03:51 EST, Alan Cox
no flags Details

  None (edit)
Description Alan Cox 2002-01-31 03:47:47 EST
(II) CHIPS(0): Not using default mode "1400x1050" (insufficient memory for
mode)(--) CHIPS(0): Virtual size is 640x480 (pitch 640)
(**) CHIPS(0): Default mode "640x480": 25.2 MHz, 31.5 kHz, 60.0 Hz
(==) CHIPS(0): DPI set to (75, 75)
(II) Loading /usr/X11R6/lib/modules/libfb.a
(II) Module fb: vendor="The XFree86 Project"
	compiled for 4.1.0, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/libxaa.a
(II) Module xaa: vendor="The XFree86 Project"
	compiled for 4.1.0, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/libramdac.a
(II) Module ramdac: vendor="The XFree86 Project"
	compiled for 4.1.0, module version = 0.1.0
Fatal server error:
Caught signal 11.  Server aborting
Comment 1 Alan Cox 2002-01-31 03:51:02 EST
Created attachment 44096 [details]
/var/log/XFree86.0.log
Comment 2 Mike A. Harris 2002-01-31 11:21:37 EST
Can you try the 4.2.0 release out for C&T Alan?  A lot of C&T
fixes went into 4.2.0.  RHL 7.2 RPM's on my people ftp dir.

ftp://people.redhat.com/mharris/testing/7.2

Need glut also, yada yada..

Lemme know how it works.

TNX
Comment 3 Mike A. Harris 2002-03-21 23:22:15 EST
er.. they're in my bleeding-edge dir now..  I gave the wrong dir above.
Comment 4 Mike A. Harris 2002-05-21 05:28:26 EDT
Any change on this in 4.2.0 in 7.3?
Comment 5 Alan Cox 2002-05-21 09:46:27 EDT
7.3 uses a gtk_imlib which has 8bit dither broken so I can't update the Red Hat
images on that machine trivially. I'll probably throw Debian on it at which point
I doubt you care anyway
Comment 6 Alan Cox 2002-09-02 17:11:06 EDT
4.2 is better, it segfaults when running not immediately. 16bit mode is broken
on the 65545, its completely broken on the 5534
Comment 7 Alan Cox 2002-09-02 17:34:43 EDT
noaccel segfaults too
Comment 8 Alan Cox 2002-09-03 14:27:41 EDT
Chased down. 8bit was crashing because of a bug in the fpit input driver for the
touchscreen. Fixed that and 8bit works.
Comment 9 Mike A. Harris 2002-12-19 04:26:36 EST
You indicated in IRC recently that the 65550 was working in rawhide.
Are these cards working now too?  Do you still have them?
Comment 10 Alan Cox 2002-12-19 07:19:14 EST
65550 is working a treat
6554x requires I build an 8.0 install set onto a PCMCIA disk for testing which
won't happen for a while
6553x I don't think I can test any more.

Comment 11 Mike A. Harris 2002-12-21 17:10:45 EST
Okee dokee..  I'll assume for now that this is also fixed.  If you find
it broken though in the future, just reopen this one or a new report,
and instead of doing config file hacks in Cards, we'll figure out WTF
is wrong and get it in the driver itself.  I hate the config file hacks
we've done in the past.  ;o/

Closing as rawhide for now..

Note You need to log in before you can comment on or make changes to this bug.