Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 591162 - no sound after waking up from suspend
no sound after waking up from suspend
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pulseaudio (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Wim Taymans
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 11:15 EDT by Máirín Duffy
Modified: 2017-12-06 07:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 07:31:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Máirín Duffy 2010-05-11 11:15:57 EDT
Description of problem:

Sound was working fine for me, then I suspended my laptop. When I opened it back up this morning, sound no longer works (tried rhythmbox, system sounds dont work, totem no sound.) I see these kinds of messages in /var/log/messages:

May 11 11:13:39 Pandaberry pulseaudio[1673]: sink-input.c: Failed to create sink input: sink is suspended.
May 11 11:13:40 Pandaberry pulseaudio[1673]: sink-input.c: Failed to create sink input: sink is suspended.
May 11 11:13:40 Pandaberry pulseaudio[1673]: sink-input.c: Failed to create sink input: sink is suspended.
May 11 11:13:40 Pandaberry pulseaudio[1673]: sink-input.c: Failed to create sink input: sink is suspended.

These messages are in /var/log/messages around the same time I first unsuspended my laptop:
May 11 09:29:09 Pandaberry pulseaudio[1673]: sink-input.c: Failed to create sink input: sink is suspended.
May 11 09:29:09 Pandaberry pulseaudio[1673]: sink-input.c: Failed to create sink input: sink is suspended.
May 11 09:29:09 Pandaberry pulseaudio[1673]: sink-input.c: Failed to create sink input: sink is suspended.
May 11 09:29:09 Pandaberry pulseaudio[1673]: sink-input.c: Failed to create sink input: sink is suspended.


Version-Release number of selected component (if applicable):

I am not sure if this is a pulseaudio issue or a driver bug or whatnot - I apologize in advance if I've filed it against the wrong component.

pulseaudio-0.9.21-8.el6.x86_64
kernel-2.6.32-23.el6.x86_64
alsa-lib-1.0.21-3.el6.x86_64
alsa-utils-1.0.21-3.el6.x86_64
alsa-plugins-pulseaudio-1.0.21-3.el6.x86_64
Comment 1 Vladimir Benes 2010-05-11 11:22:40 EDT
there is a -24 kernel .. try upgrading as it fixes some newer lenovo acpi issues
Comment 3 RHEL Product and Program Management 2010-05-11 12:44:47 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Lennart Poettering 2010-05-12 13:57:31 EDT
(In reply to comment #0)

> These messages are in /var/log/messages around the same time I first
> unsuspended my laptop:
> May 11 09:29:09 Pandaberry pulseaudio[1673]: sink-input.c: Failed to create
> sink input: sink is suspended.
> May 11 09:29:09 Pandaberry pulseaudio[1673]: sink-input.c: Failed to create
> sink input: sink is suspended.
> May 11 09:29:09 Pandaberry pulseaudio[1673]: sink-input.c: Failed to create
> sink input: sink is suspended.
> May 11 09:29:09 Pandaberry pulseaudio[1673]: sink-input.c: Failed to create
> sink input: sink is suspended.

Access to the audio device is suspended. Presumably because PA was only to resume it. Smells like a driver problem. To figure that out we'd need more log output, from the time of the resume. Also, when this happens agin please attach the output "pacmd ls" generates. Thanks.
Comment 5 RHEL Product and Program Management 2010-07-15 10:32:54 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 6 Wim Taymans 2016-08-10 05:30:31 EDT
Is this an issue we can still reproduce?
Comment 7 Máirín Duffy 2016-08-16 08:40:33 EDT
It hasn't happened again in the past 6 years that I can remember, so feel free to close :)
Comment 8 Jan Kurik 2017-12-06 07:31:11 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.