Bug 591209 - mysql-connector-java older in Beta6 than in EPEL5
mysql-connector-java older in Beta6 than in EPEL5
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mysql-connector-java (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Tom Lane
Martin Cermak
: Rebase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 12:31 EDT by Steve Traylen
Modified: 2013-07-02 23:28 EDT (History)
4 users (show)

See Also:
Fixed In Version: mysql-connector-java-5.1.12-2.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 15:36:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Traylen 2010-05-11 12:31:57 EDT
mysql-connector-java is new in Beta6 with version:

mysql-connector-java-5.1.8-2.el6.src.rpm

but EPEL5 contained

mysql-connector-java-5.1.12-2.el5.src.rpm

This could potentially make updating systems tricky.

Steve.
Comment 2 Tom Lane 2010-05-11 12:59:33 EDT
We can't realistically promise that RHEL6 will be NVR-newer than any EPEL package, especially not when the EPEL maintainer feels free to rebase once a month.  If you want to make a case that we should rebase mysql-connector-java now, I'm happy to consider it, but the decision can *not* be driven by what the EPEL maintainer is doing.
Comment 3 Steve Traylen 2010-05-11 13:25:40 EDT
In this case I am the EPEL maintainer, it's just incredibly new since it was
only added to EPEL very recently, there has only been one version ever in
EPEL.

The main reason is the nvr upgrade.

http://dev.mysql.com/doc/refman/5.1/en/cj-news-5-1.html

shows a lot bug fixes between 5.1.8 and 5.1.12.

Steve.
Comment 4 Tom Lane 2010-05-11 13:40:19 EDT
Oh, pleased to meet you --- for some reason I thought Miloš Jakubíček was handling this package in EPEL as well as Fedora.

Yeah, there are kind of a lot of bug fixes listed there :-(.  We're getting pretty late in the RHEL6 cycle for upstream rebases, but I'll put this in the request queue and see what happens.
Comment 6 RHEL Product and Program Management 2010-05-11 13:57:30 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 12 Martin Cermak 2010-06-14 09:32:26 EDT
=> VERIFIED
Comment 13 releng-rhel@redhat.com 2010-07-02 15:36:10 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.