Bug 59121 - rpm-devel is not usable
Summary: rpm-devel is not usable
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-31 11:26 UTC by Victor Vislobokov
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-31 14:39:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Victor Vislobokov 2002-01-31 11:26:09 UTC
Description of Problem: I can not compile program, because fprint.h is absent


Version-Release number of selected component (if applicable): 4.0.3, 4.0.4


How Reproducible: Error while compiling
Steps to Reproduce:
1. Type following C program into rp.c file
#include <stdio.h>
#include <rpm/rpmdb.h>

main()
{
 int rez;
 rpmdb *dbp;

 if (( rez = rpmdbOpen("/var/lib/rpm", dbp, O_RDONLY, 0)) == 0) {
   puts("Ok");
   
 }
 return 0;
}
2. Type following command
   gcc -c rp.c -I/usr/include/rpm

Actual Results: Error message
In file included from rp.c:2:
/usr/include/rpm/rpmdb.h:11:20: fprint.h: No such file or directory

Expected Results: Normal compiling

Additional Information: You must include files fprint.h and rpmhash.h into
rpm-devel package. (May be and other *.h files too)

Comment 1 Jeff Johnson 2002-01-31 14:39:03 UTC
Hmmm, no one has ever tried to use rpmdb in a standalone fashion.

Removing
	#include "fprint.h"
from rpmdb.h is probably the best thing to do, but I can be convinced
otherwise if necessary.

Off to remove fprint.h, reopen this bug if you think you need fprint.h.

Comment 2 Jeff Johnson 2002-01-31 15:01:55 UTC
Actually, you shouldn't be including rpmdb.h. Try
	#include "rpmlib.h"
Everything you need is there, not in rpmdb.h

I'm still gonna nuke the
	#include "fprint.h"


Note You need to log in before you can comment on or make changes to this bug.