Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 591214 - Group name misspelled
Group name misspelled
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pdns-recursor (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Ruben Kerkhof
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 12:50 EDT by Jonathan DeHaan
Modified: 2010-05-17 14:53 EDT (History)
1 user (show)

See Also:
Fixed In Version: pdns-recursor-3.2-2.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-17 14:51:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan DeHaan 2010-05-11 12:50:14 EDT
Description of problem:
The %pre script misspells the name of the group that pdns-recursor runs under. When doing a fresh install with this RPM, pdns-recursor starts but immediately exits. The file /var/log/messages contain entries about 'Unable to look up gid of group' and 'Unable to look up uid of user'.

Version-Release number of selected component (if applicable):
3.2-1.f11, 3.2-1.f12, 3.2-1.f13


How reproducible:
Every time.


Steps to Reproduce:
1. Install a fresh copy of F11, F12, or F13 with an updates repository, so that only the most recent updates are installed.
2. Run /etc/init.d/pdns-recursor start. You should get an 'OK'.
3. Run ps ax | grep pdns. You will not see the pdns_recursor --daemonize in the output from ps.
4. Run grep pdns /etc/group. You will see an entry for pdns-recursur.
5. Run grep pdns /etc/passwd. You will not see any entry for pdns-recursor.
  
Actual results:
A group is created with the name 'pdns-recursur'. No user is created with the name 'pdns-recursor'. Pdns-recursor exits immediately after startup.

Expected results:
A group should be created with the name 'pdns-recursor'. A user should be created with the name 'pdns-recursor'. Pdns-recursor should continue to run and serve DNS requests when it is started.

Additional info:
There is a misspelling in the SPEC file for pdns-recursor 3.2 for at least F11, F12, and F13. The groupadd command adds a group called 'pdns-recursur' instead of 'pdns-recursor'. This causes the useradd command to fail, because it cannot find the group that the 'pdns-recursor' user should belong to. The error does not occur if you upgrade to 3.2, because the previous version(s) created the correct user and group, so a new one does not need to be added.
Comment 1 Ruben Kerkhof 2010-05-13 12:10:06 EDT
Thanks for the report. This typo slipped through the cracks since I only tested the upgrade path, not a new install.
Comment 2 Fedora Update System 2010-05-13 13:54:40 EDT
pdns-recursor-3.2-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/pdns-recursor-3.2-2.fc13
Comment 3 Fedora Update System 2010-05-13 13:55:22 EDT
pdns-recursor-3.2-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/pdns-recursor-3.2-2.fc12
Comment 4 Fedora Update System 2010-05-13 13:57:20 EDT
pdns-recursor-3.2-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/pdns-recursor-3.2-2.fc11
Comment 5 Fedora Update System 2010-05-15 16:17:12 EDT
pdns-recursor-3.2-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pdns-recursor'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/pdns-recursor-3.2-2.fc13
Comment 6 Fedora Update System 2010-05-15 16:34:13 EDT
pdns-recursor-3.2-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pdns-recursor'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/pdns-recursor-3.2-2.fc12
Comment 7 Fedora Update System 2010-05-15 16:39:51 EDT
pdns-recursor-3.2-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pdns-recursor'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/pdns-recursor-3.2-2.fc11
Comment 8 Jonathan DeHaan 2010-05-17 12:33:18 EDT
Tested pdns-recursor-3.2-2.fc13 and confirmed that it does work.
Comment 9 Fedora Update System 2010-05-17 14:50:56 EDT
pdns-recursor-3.2-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2010-05-17 14:52:11 EDT
pdns-recursor-3.2-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2010-05-17 14:53:34 EDT
pdns-recursor-3.2-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.