Bug 591258 - Dim display after suspend does not work any more
Dim display after suspend does not work any more
Status: CLOSED DUPLICATE of bug 582664
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 14:35 EDT by François Kooman
Modified: 2010-10-07 15:40 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-07 15:40:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description François Kooman 2010-05-11 14:35:25 EDT
Description of problem:

Dimming the display on MacBook Pro 13" 5,5 works perfectly before suspend. With the buttons (f1,f2) and automatically when unplugging power cable. Using stock F13 rawhide as of today (Tue May 11 18:31:43 UTC 2010). I'm using the nouveau driver.

Version-Release number of selected component (if applicable):

upower-0.9.2-1.fc13.x86_64
gnome-power-manager-2.30.1-1.fc13.x86_64
kernel-2.6.33.3-85.fc13.x86_64
xorg-x11-drv-nouveau-0.0.16-3.20100305git6b8b157.fc13.x86_64

How reproducible:

Always

Steps to Reproduce:
1. try to modify the display brightness with buttons and by unplugging power cord and reattaching again
2. see the dimming work
3. suspend the system by closing the lid
4. resume the system by opening the lid
5. try to modify the brightness again (either buttons or unplugging cord)

Actual results:

No more dimming.

Expected results:

Dimming.

Additional info:

Gnome does detect the display dimming key presses (f1,f2) and shows the "progress" bar indicating the dimming of the display but the display doesn't actually get dimmed.

How can I better debug this? Let me know if you need me to do anything to get more information.
Comment 1 Richard Hughes 2010-05-11 14:39:52 EDT
Smells like a kernel problem, no?
Comment 2 Kevin Fenzi 2010-07-03 14:57:40 EDT
Could well be. Moving it over to the nouveau component for further debugging.
Comment 3 Bug Zapper 2010-07-30 07:36:20 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Adam Williamson 2010-10-07 15:40:18 EDT

*** This bug has been marked as a duplicate of bug 582664 ***

Note You need to log in before you can comment on or make changes to this bug.