Bug 591299 - [RHEL6] 2.6.32-25.el6 crashes with bad page state
[RHEL6] 2.6.32-25.el6 crashes with bad page state
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Rik van Riel
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 16:13 EDT by Aristeu Rozanski
Modified: 2010-11-10 13:55 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-08 12:02:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aristeu Rozanski 2010-05-11 16:13:17 EDT
Description of problem:
while testing 2.6.32-25.el6:
BUG: Bad page state in process load_policy  pfn:fe0e8141
page:c1d02820 flags:b35b88dd count:0 mapcount:-1285846693 mapping:b35b89d7 index:0 (Not tainted)
Pid: 444, comm: load_policy Not tainted 2.6.32-25.el6.i686 #1
Call Trace:
 [<c04dd19b>] ? bad_page+0xfb/0x150
 [<c04de464>] ? get_page_from_freelist+0x484/0x530
 [<c04de5fc>] ? __alloc_pages_nodemask+0xec/0x640
 [<c0508a64>] ? cache_alloc_refill+0x1c4/0x550
 [<c0508b97>] ? cache_alloc_refill+0x2f7/0x550
 [<c0509008>] ? kmem_cache_alloc_notrace+0x88/0xc0
 [<c05a3239>] ? cond_insertf+0xf9/0x1e0
 [<c059b38e>] ? avtab_read_item+0x27e/0x360
 [<c0454635>] ? irq_exit+0x35/0x70
 [<c0423a44>] ? smp_apic_timer_interrupt+0x54/0x90
 [<c040a295>] ? apic_timer_interrupt+0x31/0x38
 [<c05a33e1>] ? cond_read_av_list+0x91/0xc0
 [<c05a3140>] ? cond_insertf+0x0/0x1e0
 [<c05a372f>] ? cond_read_list+0x1cf/0x330
 [<c059ada0>] ? avtab_insertf+0x0/0x140
 [<c059db43>] ? policydb_read+0x4a3/0x1340
 [<c05097c0>] ? enable_cpucache+0x30/0xd0
 [<c080ad81>] ? mutex_lock+0x11/0x40
 [<c059cd00>] ? cat_read+0x0/0x160
 [<c05a026f>] ? security_load_policy+0x5f/0x3f0
 [<c04af571>] ? delayacct_end+0xa1/0xc0
 [<c0476bea>] ? ktime_get_ts+0xda/0x100
 [<c04af5ea>] ? __delayacct_blkio_end+0x2a/0x50
 [<c080a9a9>] ? __wait_on_bit_lock+0x59/0x90
 [<c04d0dd0>] ? sync_page+0x0/0x40
 [<c04d0db0>] ? __lock_page+0x80/0x90
 [<c04d0b9d>] ? find_get_page+0x1d/0x90
 [<c04d2726>] ? filemap_fault+0xa6/0x440
 [<c043458a>] ? kmap_atomic_prot+0x11a/0x150
 [<c0434427>] ? kunmap_atomic+0x67/0x80
 [<c04f1219>] ? __do_fault+0x429/0x4e0
 [<c04f1e6d>] ? handle_pte_fault+0xcd/0xc70
 [<c04f2b42>] ? handle_mm_fault+0x132/0x1d0
 [<c080e040>] ? do_page_fault+0x150/0x400
 [<c080def0>] ? do_page_fault+0x0/0x400
 [<c080c04b>] ? error_code+0x73/0x78
 [<c059007b>] ? may_create+0xdb/0x140
 [<c0597286>] ? sel_write_load+0xb6/0x650
 [<c0592837>] ? selinux_file_permission+0xe7/0x130
 [<c05874bc>] ? security_file_permission+0xc/0x10
 [<c0514c66>] ? rw_verify_area+0x66/0xe0
 [<c05971d0>] ? sel_write_load+0x0/0x650
 [<c0514d80>] ? vfs_write+0xa0/0x190
 [<c0515811>] ? sys_write+0x41/0x70
 [<c040985b>] ? sysenter_do_call+0x12/0x28

http://rhts.redhat.com/testlogs/2010/05/156386/401412/3247477/boot.kernel-2.6.32-25.el6

Version-Release number of selected component (if applicable):
2.6.32-25.el6

How reproducible:
Unknown, first time and happened only in one machine
Comment 2 RHEL Product and Program Management 2010-05-11 17:56:53 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Rik van Riel 2010-06-08 12:02:52 EDT
Since this bug has not been reproduced again and there are no hints in the code as to how this could ever happen ... CLOSED / WORKSFORME

Note You need to log in before you can comment on or make changes to this bug.