Bug 591448 - Performance degradation with AMD PhenomII X6 Turbo-Core feature
Summary: Performance degradation with AMD PhenomII X6 Turbo-Core feature
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-12 09:43 UTC by Andre Przywara
Modified: 2010-06-03 08:06 UTC (History)
7 users (show)

Fixed In Version: 2.6.33.4-95
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-21 03:49:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andre Przywara 2010-05-12 09:43:30 UTC
Description of problem:
AMD's Six-Core processor have a Turbo-Core feature automatically activated without software involvement. Due to a conflict with the powernow-k8 driver this feature is not activated under recent Linux kernel versions, resulting in bad performance.

Version-Release number of selected component (if applicable):
all Linux kernels starting from 2.6.30, including the Fedora13 version

How reproducible:
Do performance testing with AMD's desktop Six-Core processors featuring Turbo-Core (PhenomII X6 1090T and 1055T). Compare the performance to that with the Cool'n'Quiet _disabled_ in the BIOS.

Steps to Reproduce:
1. Boot Fedora13 on an AMD PhenomII X6 processor
2. Do some performance testing
3. Disable Cool'n'Quiet feature in the BIOS
4. Repeat performance testing, compare numbers to that of Step2
  
Actual results:
Performance with C'n'Q enabled is worse than with C'n'Q disabled.

Expected results:
Performance with C'n'Q enabled should be equal or better compared to C'n'Q disabled.

Additional info:
Following online articles describe the problem:
http://www.h-online.com/open/news/item/Performance-problem-in-AMD-s-Phenom-II-X6-under-Linux-993127.html
http://www.linux-magazine.com/Online/News/Phenom-II-X6-Performance-Under-Linux-Below-Expectations

Comment 1 Andre Przywara 2010-05-12 09:48:46 UTC
The appropriate fix (a one-liner):
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=b810e94c9d8e3fff6741b66cd5a6f099a7887871
is already in 2.6.34-rc7 and will trickle down into stable soon.
Please cherry-pick this one into the Fedora13 release kernel.


Note You need to log in before you can comment on or make changes to this bug.