Bug 591470 - syslinux should be included on DVD media, which can be used as a repo for livecd-tools/livecd-creator
syslinux should be included on DVD media, which can be used as a repo for liv...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-12 06:39 EDT by Jasper O'neal Hartline
Modified: 2014-03-16 23:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-21 15:56:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jasper O'neal Hartline 2010-05-12 06:39:04 EDT
Description of problem:
syslinux is not a base package included in the DVD install media which livecd-tools livecd-creator needs, therefore preventing any user to use livecd-creator without configuring an online repository source for an "Everything" tree, to use a source repository.. this is impossible for people who do not have network, and do not have a local mirror of the Everything tree.

Please get syslinux into the main DVD installer tree, rather than in Everything since livecd-creator needs it.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
syslinux into the main DVD installer tree, rather than in Everything since livecd-creator needs it.

Additional info:
Comment 1 Jasper O'neal Hartline 2010-06-25 08:54:48 EDT
Apparently RHEL 5 DVD has it on there, so it was moved somehow maybe by accident, or on purpose. In any case can we move it back to the base DVD not the Everything tree.
Comment 2 Jasper O'neal Hartline 2010-07-22 03:51:56 EDT
Is there any sort of comment or concensus I can get as far as this problem is concerned? It seems to use livecd-creator locally, without network and by rsync'ing an Everything tree, I must download 20GB of data, for Fedora 13 i386/i686 for example to use livecd-creator without smashing my computer to pieces.

This all because of the placement and requirement on syslinux, a single package which is something under a 1MB in RPM form.
Comment 3 Jasper O'neal Hartline 2010-07-22 18:14:32 EDT
Testing shows a networked repository took 19 minutes to complete a CD build using livecd-creator, using a local repository took 7 minutes.

This is a huge difference in time and also would reduce the 20GB Evrything tree someone must download to use livecd-creator to 3.3GB which is the size of the DVD media.
Comment 4 Bug Zapper 2010-07-30 07:36:48 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bill Nottingham 2011-02-21 15:56:43 EST
Done for F15/F16.

Note You need to log in before you can comment on or make changes to this bug.