Bug 591586 - Corrupted graphical installer on nVidia FX1400 graphics card
Summary: Corrupted graphical installer on nVidia FX1400 graphics card
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-12 15:57 UTC by James Pearson
Modified: 2010-05-31 00:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-31 00:23:01 UTC
Target Upstream Version:


Attachments (Terms of Use)
/tmp/X.log (41.40 KB, text/plain)
2010-05-14 10:12 UTC, James Pearson
no flags Details
Screen shot (125.87 KB, image/jpeg)
2010-05-14 10:15 UTC, James Pearson
no flags Details

Description James Pearson 2010-05-12 15:57:47 UTC
Description of problem:

As soon as the graphical part of the installer is launched, the display is corrupted and unusable

Version-Release number of selected component (if applicable):

RHEL6.0-20100414.0-AP-x86_64

How reproducible:

Boot RHEL6.0-20100414 DVD

Steps to Reproduce:
1. Boot RHEL6.0-20100414 DVD
2.
3.
  
Actual results:

Corrupted display

Expected results:

Non-corrupted display

Additional info:

Workstation is a dual Opteron (252) system with an nVidia based CK804 motherboard. The graphics card is an nVidia FX1400

Display is corrupted using either the standard or basic install menu item

Comment 1 James Pearson 2010-05-12 16:17:47 UTC
I notice that the 'Component' has changed from 'anaconda' to 'xorg-x11-drv-nouveau' - however, I get the _same_ issue when booting the installer using the 'basic' video driver install menu item. In this case, the boot cmdline has 'xdriver=vesa'

I assume the nouveau driver isn't used in this case?

Comment 3 RHEL Program Management 2010-05-12 18:07:33 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 Ben Skeggs 2010-05-12 23:16:26 UTC
Yes, one would assume nouveau is not at fault if it's also failing with the "basic" video driver,  I assume that also sets "nomodeset" as well as "xdriver=vesa" ?

Comment 5 James Pearson 2010-05-13 09:16:30 UTC
Yes, the "basic" video mode sets "nomodeset" as well

I also tried "nomodeset" with the standard ("nouveau") video mode - but that made no difference

Comment 6 Ben Skeggs 2010-05-13 23:06:40 UTC
Okay, well this can't be nouveau then in that case as you suspected.  Are you able to provide your X log from after the corruption when running with the vesa driver?  And can you give any more detail on the corruption you're seeing?

I'll reassign to the X server for now, it's probably the next likely candidate!

Comment 7 James Pearson 2010-05-14 10:12:25 UTC
Created attachment 413998 [details]
/tmp/X.log

Comment 8 James Pearson 2010-05-14 10:15:49 UTC
Created attachment 414001 [details]
Screen shot

Hard to describe the screen corruption - so here is a photo of the screen

Comment 9 James Pearson 2010-05-14 13:58:47 UTC
I've just tried to install Fedora 12 on this hardware - and get the same issue.

Comment 10 James Pearson 2010-05-21 15:12:39 UTC
I've installed the latest BIOS for this hardware - and now the installer starts X fine.

I'm not sure if it was the new BIOS, or the fact that installing a new BIOS resets the BIOS settings that fixed the issue.

Anyway, I have now installed RHEL6 beta1 on this machine - so I guess this can be closed

Comment 11 Dave Airlie 2010-05-31 00:23:01 UTC
reported has done a new BIOS + reset settings, so closing as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.