Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 591651 - [RFE] add attribute that describes a systems as production or pre-production
[RFE] add attribute that describes a systems as production or pre-production
Status: CLOSED NOTABUG
Product: Beaker
Classification: Community
Component: inventory (Show other bugs)
0.5
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Bill Peck
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-12 15:24 EDT by Cameron Meadors
Modified: 2012-09-27 20:34 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-27 20:34:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cameron Meadors 2010-05-12 15:24:23 EDT
There are many systems in rhts that are pre-production (engineering samples) that were added because at the time there was no released hardware and we needed to run automated tests.  We are running into situations where the engineering samples don't always install (because they are beta quality at best).  Also we don't want to be testing on pre-production hardware unless we are doing hardware enablement testing.

I suggest that there should be a way to describe a systems as pre-production (engineering sample/beta quality) or production (released/supported) hardware.  Then testers can decide what if it is ok to test on pre-production hardware or not.
Comment 1 Dan Callaghan 2011-02-01 23:04:00 EST
Is this solved by having "Machine" vs. "Prototype" in the "type" field for a system?
Comment 2 Dan Callaghan 2012-09-27 20:34:58 EDT
Assuming this is solved by using "Prototype" for the system type.

Note You need to log in before you can comment on or make changes to this bug.