Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 591708 - DeviceError: ('cannot replace active format', 'sda1')
DeviceError: ('cannot replace active format', 'sda1')
Status: CLOSED DUPLICATE of bug 570474
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
anaconda_trace_hash:1e4f71bb6bfec6a32...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-12 17:00 EDT by Dennis Gilmore
Modified: 2010-07-01 05:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-12 17:56:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (167.77 KB, text/plain)
2010-05-12 17:01 EDT, Dennis Gilmore
no flags Details
Attached traceback automatically from anaconda. (143.71 KB, text/plain)
2010-07-01 05:58 EDT, Vimal Kumar
no flags Details

  None (edit)
Description Dennis Gilmore 2010-05-12 17:00:58 EDT
The following was filed automatically by anaconda:
anaconda 13.21.20.5 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 697, in _setFormat
    raise DeviceError("cannot replace active format", self.name)
  File "/usr/lib/anaconda/storage/devices.py", line 1171, in _setFormat
    StorageDevice._setFormat(self, format)
  File "/usr/lib/anaconda/storage/devices.py", line 705, in <lambda>
    lambda d,f: d._setFormat(f),
  File "/usr/lib/anaconda/storage/deviceaction.py", line 307, in __init__
    self.device.format = None
  File "/usr/lib/anaconda/storage/__init__.py", line 782, in destroyDevice
    self.devicetree.registerAction(ActionDestroyFormat(device))
  File "/usr/lib/anaconda/storage/partitioning.py", line 370, in clearPartitions
    storage.destroyDevice(part)
  File "/usr/lib/anaconda/kickstart.py", line 301, in execute
    clearPartitions(anaconda.id.storage)
  File "/usr/lib/anaconda/kickstart.py", line 1086, in execute
    obj.execute(self.anaconda)
  File "/usr/bin/anaconda", line 1035, in <module>
    ksdata.execute()
DeviceError: ('cannot replace active format', 'sda1')
Comment 1 Dennis Gilmore 2010-05-12 17:01:00 EDT
Created attachment 413561 [details]
Attached traceback automatically from anaconda.
Comment 2 Dennis Gilmore 2010-05-12 17:29:59 EDT
This was doing a kickstart reinstall with "clearpart --all" in the kickstart file
Comment 3 David Lehman 2010-05-12 17:56:40 EDT

*** This bug has been marked as a duplicate of bug 570474 ***
Comment 4 Vimal Kumar 2010-07-01 05:58:09 EDT
Created attachment 428223 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.