Bug 591843 - abrt-cli: crash 'XXXXXXXX' is not in database
abrt-cli: crash 'XXXXXXXX' is not in database
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Karel Klíč
Michal Nowak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-13 06:55 EDT by Michal Nowak
Modified: 2013-03-07 21:09 EST (History)
10 users (show)

See Also:
Fixed In Version: abrt-1.1.5-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 14:32:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log from abrtd -dvvvvv (8.04 KB, text/plain)
2010-05-13 06:55 EDT, Michal Nowak
no flags Details
Proposed patch (3.07 KB, patch)
2010-05-26 11:20 EDT, Denys Vlasenko
no flags Details | Diff

  None (edit)
Description Michal Nowak 2010-05-13 06:55:53 EDT
Created attachment 413713 [details]
log from abrtd -dvvvvv

Description of problem:

For every crash I trie to report via abrt-cli (thought I tested python exceptions only) I get:

"""
dhcp-lab-222 ~ # abrt-cli --report-always 5505cbf4
>! crash '5505cbf4' is not in database
>! Can't find crash with id 5505cbf4 in database
Reporting...
>> Creating a TicketUploader report...

>> Reporting via 'Bugzilla' was not successful: Empty login or password.
Please check /etc/abrt/plugins/Bugzilla.conf.
>> Writing report to '/var/log/abrt.log'
Bugzilla: Empty login or password.
Please check /etc/abrt/plugins/Bugzilla.conf.
Logger: file:///var/log/abrt.log
TicketUploader: Please send this to your technical support:
========cut here========
RHUPLOAD: This report was copied into /tmp/:
FILE: TicketUploader-newticket-20100513104433.tar.gz
MD5SUM: db9e16daf904979720e0091948cfd9c9  -
==========end===========

Crash reported via 3 plugins (1 errors)
"""

both with `--report` and `--report-always`.

Log from `abrtd -dvvvvv` attached.

Version-Release number of selected component (if applicable):

abrt-1.1.0-1.el6.x86_64

How reproducible:

always

Expected results:

abrt should not report it can't find that UUID in DB, when it actually does. (I know it does because `abrt-cli --report 5505cbf4` shows the traceback in $EDITOR as well as that error msg.)

Additional info:
Comment 1 RHEL Product and Program Management 2010-05-13 07:37:17 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Michal Nowak 2010-05-26 10:28:21 EDT
Still in abrt-1.1.4-1.el6.x86_64 (unofficial one).


dhcp-lab-222 yum.repos.d # abrt-cli --get-list-full | grep 8de4eda1421d35882ba1af51051775770dc4ee14
	UUID       : 8de4eda1421d35882ba1af51051775770dc4ee14

dhcp-lab-222 yum.repos.d # abrt-cli --report-always 8de4eda1421d35882ba1af51051775770dc4ee14
>! crash '8de4eda1421d35882ba1af51051775770dc4ee14' is not in database
>! Can't find crash with id 8de4eda1421d35882ba1af51051775770dc4ee14 in database
Reporting...


I guess this is the kind of errors support folks would like to have removed.
Comment 3 Denys Vlasenko 2010-05-26 11:20:32 EDT
Created attachment 416877 [details]
Proposed patch
Comment 4 Denys Vlasenko 2010-05-26 11:20:47 EDT
Fixed in git.
Comment 7 Denys Vlasenko 2010-06-02 14:04:20 EDT
It will be in abrt-1.1.5-1 as soon as it will be built...
Comment 11 releng-rhel@redhat.com 2010-11-10 14:32:58 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.