Bug 591870 - Set shell for root user on RHEVH to put the user directly into the *-config-setup menu instead of dropping them to a bash prompt
Summary: Set shell for root user on RHEVH to put the user directly into the *-config-s...
Keywords:
Status: CLOSED DUPLICATE of bug 591864
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Alan Pevec
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 508540
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-13 11:43 UTC by Perry Myers
Modified: 2010-07-02 18:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 591864
Environment:
Last Closed: 2010-07-02 18:48:29 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Perry Myers 2010-05-13 11:43:56 UTC
+++ This bug was initially created as a clone of Bug #591864 +++

Description of problem:
To make it really clear to end users that logging in via ssh/console and using normal bash shell/command line tools is unsupported, we should change the shell for root to put the user directly into the ovirt-config-setup tool.

From there, the user can always still get a bash prompt by using the menu option for getting a bash prompt.  But doing it this way, they have to agree to only go to a bash prompt if they are being instructed to do so by support.

Long term for RHEVH in RHEL6, we're going to do this by using a nicer menuing system.  But for RHEVH5.X we might want to just make this small tweak anyhow.

The only negative here is that since RHEVM uses root ssh access to connect to RHEVH this will be problematic.  But we should probably change RHEVM to use a non-root account to connect to both RHEL and RHEVH hosts anyhow.  Perhaps a 'rhevm' user that has sudo privileges.  This rhevm user and the sudo configuration could be set up as part of the vdsm package install (At least that would work on RHEVH, not sure if there is a chicken/egg problem on RHEL hosts)

Comment 1 RHEL Program Management 2010-05-13 12:48:25 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 Perry Myers 2010-07-02 18:48:29 UTC

*** This bug has been marked as a duplicate of bug 591864 ***


Note You need to log in before you can comment on or make changes to this bug.