Bug 591882 - Support for merging grub configuration files of older RHEL releases
Summary: Support for merging grub configuration files of older RHEL releases
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 6.0
Hardware: All Linux
high
medium
Target Milestone: rc
: ---
Assignee: Radek Vykydal
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords: FutureFeature, Reopened
Depends On:
Blocks: 647893
TreeView+ depends on / blocked
 
Reported: 2010-05-13 12:34 UTC by David Kovalsky
Modified: 2014-03-31 23:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-15 23:36:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (1) (1.36 MB, image/jpeg)
2010-05-13 12:39 UTC, David Kovalsky
no flags Details
screenshot (2) (867.54 KB, image/jpeg)
2010-05-13 12:40 UTC, David Kovalsky
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 568542 None None None Never

Description David Kovalsky 2010-05-13 12:34:13 UTC
I'm installing RHEL6 Beta2 to a disk which already has LVM configured and RHEL5. 

Structure:
sda1 - 200MB boot
sda2 - ~160GB LVM

LVM:
 * vg_root_kovy
   * lv_root_1 (ext3, has RHEL5)
   * lv_root_2 (ext4, trying to install RHEL6 here)
   * lv_root_3 ...
   * lv_root_4 ...


I want to make sure that when I install grub to sda1 I don't lose my RHEL5 entries, which Boot loader operating system list seems to suggest.

So I added an entry "Red Hat Enterprise Linux 5", but when I hit 'edit' it doesn't allow me to select device different from 'sda1'. RHEL6 is correctly setup for vg_root_kovy-lv_root_2.

This is not very user friendly, since I'm left with 2 bad choices:
 * do not install grub. After RHEL6 install boot RHEL5 and add the entries manually. 

 * install grub. Boot RHEL6 and add RHEL5 entries back.

Comment 1 David Kovalsky 2010-05-13 12:39:26 UTC
Created attachment 413743 [details]
screenshot (1)

Comment 2 David Kovalsky 2010-05-13 12:40:09 UTC
Created attachment 413746 [details]
screenshot (2)

Comment 4 RHEL Product and Program Management 2010-05-13 14:07:08 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 5 Radek Vykydal 2010-05-19 11:44:33 UTC
The "Boot loader operating system list" is not there for automatic merging of (grub) boot configurations (we don't support it) but for chain-loading, that is, for your case you'd need to keep old RHEL5 boot partition, have bootloader installed in it, and for RHEL6 create a new boot partition from which grub would chain-load the RHEL5 boot partition bootloader. I am closing this as NOTABUG, you can open RFE for the requested feature. We have already one similar bug #568542 for Fedora.

Comment 6 David Kovalsky 2010-05-19 12:03:23 UTC
Alright, reopening this then as an RFE

Adding another system in bootloader configuration doesn't work
->
Support for merging grub configuration files of older RHEL releases

Comment 7 RHEL Product and Program Management 2010-05-19 12:19:30 UTC
This feature request did not get resolved in time for Feature Freeze
for the current Red Hat Enterprise Linux release and has now been
denied. You may re-open your request by requesting your support
representative to propose it for the next release.

Comment 9 David Cantrell 2010-11-15 23:36:01 UTC
Merging an existing /boot with a new /boot is not supported in anaconda.  This is a very tricky area to get in to and would introduce many problems if people have other Linux distributions installed.  It is not a use case we want to support in anaconda.


Note You need to log in before you can comment on or make changes to this bug.