Bug 591905 - [abrt] crash in audacity-1.3.11-0.1.beta.fc12: snd_mask_leave: Process /usr/bin/audacity was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in audacity-1.3.11-0.1.beta.fc12: snd_mask_leave: Process /usr/b...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: alsa-lib   
(Show other bugs)
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jaroslav Kysela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b84c3d75122645c89d96643c961...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-13 13:11 UTC by Maarten
Modified: 2010-08-15 13:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-15 13:09:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (42.94 KB, text/plain)
2010-05-13 13:11 UTC, Maarten
no flags Details

Description Maarten 2010-05-13 13:11:45 UTC
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: audacity
component: audacity
crash_function: snd_mask_leave
executable: /usr/bin/audacity
global_uuid: b84c3d75122645c89d96643c96176a517c647e12
kernel: 2.6.32.11-99.fc12.i686.PAE
package: audacity-1.3.11-0.1.beta.fc12
rating: 4
reason: Process /usr/bin/audacity was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. in terminal, type audacity
2. causes segmentation fault (core dumped)
3.

Comment 1 Maarten 2010-05-13 13:11:47 UTC
Created attachment 413756 [details]
File: backtrace

Comment 2 Michael Schwendt 2010-05-24 10:31:37 UTC
A crash deep in alsa-lib.

Comment 3 David Timms 2010-07-09 13:57:17 UTC
Maarten: would you be able to provide info about your soundcard hardware by running:
alsa-info.sh
and pasting the upload URL it gives you into this bug.

Secondly, was this a one time only crash, or was it repeatable ?

Comment 4 Maarten 2010-07-15 18:58:33 UTC
Sorry for the delay. The crash doesn't seem to happen anymore. 

The url given is www.alsa-project.org

Comment 5 David Timms 2010-07-15 22:09:15 UTC
(In reply to comment #4)
> The url given is www.alsa-project.org    
Maarten: sorry I was unclear. Usually alsa-info.sh finishes, leaving a complete URL, like (my machine):
http://www.alsa-project.org/db/?f=1a779912ed2b3967f1384fc66bd635d875b6355e

Can you provide the equivalent link for your sound hardware ?

Comment 7 David Timms 2010-08-15 13:09:50 UTC
Thanks for reporting this bug with audacity-1.3.11-0.1.beta.fc12.

It's possible that the bug has been fixed in the current beta or was a problem with one of audacity's supporting libraries that has since been updated. The following builds are available:
audacity-1.3.12-0.4.beta for fc12/13/14

As you mention, perhaps an alsa-libs update has resolved this issue, since you hadn't seen it recently, hence this bug is being closed as errata.

Should you find that you can reproduce this identical issue with 1.3.12, please re-open this bug, setting the Fedora release and indicating the audacity version.


Note You need to log in before you can comment on or make changes to this bug.