Bug 591924 - ntp rpm verification fails on /etc/ntp.conf
Summary: ntp rpm verification fails on /etc/ntp.conf
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ntp   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
low
Target Milestone: rc
: ---
Assignee: Miroslav Lichvar
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-13 13:50 UTC by Miroslav Lichvar
Modified: 2010-11-10 21:15 UTC (History)
4 users (show)

Fixed In Version: ntp-4.2.4p8-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 481151
Environment:
Last Closed: 2010-11-10 21:15:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Miroslav Lichvar 2010-05-13 13:50:44 UTC
+++ This bug was initially created as a clone of Bug #481151 +++

Description of problem:
rpm verify test of the package ntp fails on its configuration file /etc/ntp.conf

but this file may be automagically changed by dhclient-script which is the default configuration, and so it could not be expected that it will match the package's version

Version-Release number of selected component (if applicable):
ntp-4.2.2p1-9.el5_3.1

How reproducible:
always (on systems where dhclient can set ntp configuration)

Steps to Reproduce:
1. rpm -V ntp
  
Actual results:
S.5....T  c /etc/ntp.conf

Expected results:
(no error output)

Additional info:
I propose changing the corresponding .spec line to:
%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ntp.conf

the issue is present also on RHEL-4

Comment 1 RHEL Product and Program Management 2010-05-13 14:06:30 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 releng-rhel@redhat.com 2010-11-10 21:15:29 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.