Bug 59205 - "the primary link for print must be /usr/bin/cancel"
"the primary link for print must be /usr/bin/cancel"
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: cups (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-02 04:54 EST by Bill Crawford
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-02 05:53:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
How to fix the problem ... :o) (6.21 KB, text/plain)
2002-02-02 05:30 EST, Bill Crawford
no flags Details

  None (edit)
Description Bill Crawford 2002-02-02 04:54:51 EST
Description of Problem:

The alternatives system needs tweaking (yes, I know it's all very new :o)

Just to be sure the script was from the newest package, I did a force-upgrade
afterwards, the error was still there:

[root@pikachu tmp]# rpm -Uvh --force LPRng-3.8.5-2.i386.rpm 
Preparing...                ########################################### [100%]
   1:LPRng                  ########################################### [100%]
the primary link for print must be /usr/bin/cancel
error: execution of %post scriptlet from LPRng-3.8.5-2 failed, exit status 2
Comment 1 Tim Waugh 2002-02-02 04:58:28 EST
The primary link should in fact be /usr/bin/lpr, so it must be a cups bug.
Comment 2 Bill Crawford 2002-02-02 05:24:39 EST
I can try that out ... hold on ... that's not the only cups bug :o)
[root@pikachu tmp]# rpm -e cups qtcups gimp-print-cups cups-drivers
cupsd: unrecognized service

I'll go file that one in a minute or three.

Hmm ...
[root@pikachu tmp]# rpm -e LPRng printconf printconf-gui
/usr/bin/lpr.LPRng has not been configured as an alternative for print
error: execution of %postun scriptlet from LPRng-3.8.5-2 failed, exit status 2

OK, not sure about this:
[root@pikachu tmp]# rpm -Uvh LPRng-3.8.5-2.i386.rpm printconf-*
Preparing...                ########################################### [100%]
   1:LPRng                  ########################################### [ 33%]
the primary link for print must be /usr/bin/cancel
error: execution of %post scriptlet from LPRng-3.8.5-2 failed, exit status 2
   2:printconf              ########################################### [ 66%]
   3:printconf-gui          ########################################### [100%]

It's still not happy.  Is it easy to remove whatever stored config exists for
the alternatives?
(I am going to go GTFCF [grep the ******* configuration files] in a sec ...)
Comment 3 Bill Crawford 2002-02-02 05:29:10 EST
Ah, you're right.  Additional info attached in a tick ...
Comment 4 Bill Crawford 2002-02-02 05:30:52 EST
Created attachment 44356 [details]
How to fix the problem ... :o)
Comment 5 Bernhard Rosenkraenzer 2002-02-02 05:53:20 EST
This was fixed yesterday.
Comment 6 Bill Crawford 2002-02-02 07:08:24 EST
That'll teach me not to wait a day to see if gets fixed because it's obvious ;o)

Note You need to log in before you can comment on or make changes to this bug.