Bug 59206 - Name of the "cups" service is assumed to be "cupsd" in several places
Summary: Name of the "cups" service is assumed to be "cupsd" in several places
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: cups   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 61590
TreeView+ depends on / blocked
 
Reported: 2002-02-02 10:36 UTC by Bill Crawford
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-28 09:00:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Crawford 2002-02-02 10:36:44 UTC
Description of Problem:

Name of the "cups" service is assumed to be "cupsd" in several places:

[root@pikachu tmp]# rpm -Uvh --force cups-* qtcups-*
gimp-print-cups-4.2.0-2.i386.rpm 
Preparing...                ########################################### [100%]
   1:cups-libs              ########################################### [ 11%]
   2:cups                   ########################################### [ 22%]
error reading information on service cupsd: No such file or directory
the primary link for print must be /usr/bin/lpr
error: execution of %post scriptlet from cups-1.1.13-2 failed, exit status 2
   3:cups-devel             ########################################### [ 33%]
   4:cups-drivers           ########################################### [ 44%]
cupsd: unrecognized service
   5:qtcups                 ########################################### [ 55%]
   6:qtcups-devel           ########################################### [ 66%]
   7:gimp-print-cups        ########################################### [ 77%]
cupsd: unrecognized service
error: execution of %post scriptlet from gimp-print-cups-4.2.0-2 failed, exit
status 1


Version-Release number of selected component (if applicable):
[root@pikachu tmp]# rpm -q cups cups-drivers gimp-print-cups
cups-1.1.13-2
cups-drivers-1.0.0-3
gimp-print-cups-4.2.0-2

Comment 1 Bernhard Rosenkraenzer 2002-02-02 10:49:31 UTC
Already noticed and fixed yesterday.

Comment 2 Enrico Scholz 2002-02-19 12:30:46 UTC
Still in /etc/init.d/cups of cups-1.1.14-1:

| DAEMON=cupsd
| start() {
| ...
| ... touch /var/lock/subsys/$DAEMON

This prevents terminating of cups at system-shutdown since initscripts are
executing /etc/rc6.d/K00cups only, if /var/lock/subsys/cups exists.

Comment 3 Bill Nottingham 2002-04-02 17:32:18 UTC
Fixed in -11.


Note You need to log in before you can comment on or make changes to this bug.