Bug 592061 - partx infinite loop
Summary: partx infinite loop
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: util-linux-ng   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 594689
TreeView+ depends on / blocked
 
Reported: 2010-05-13 19:01 UTC by Andy Lutomirski
Modified: 2010-06-18 08:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 594689 (view as bug list)
Environment:
Last Closed: 2010-06-18 08:17:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andy Lutomirski 2010-05-13 19:01:14 UTC
# partx -d /dev/sda

[hangs]

# strace partx -d /dev/sda

execve("/sbin/partx", ["partx", "-d", "/dev/sda"], [/* 47 vars */]) = 0
brk(0)                                  = 0x11d6000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f617c0d2000
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=78932, ...}) = 0
mmap(NULL, 78932, PROT_READ, MAP_PRIVATE, 3, 0) = 0x7f617c0be000
close(3)                                = 0
open("/lib64/libc.so.6", O_RDONLY)      = 3
read(3, "\177ELF\2\1\1\3\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0p\355!\2000\0\0\0"..., 832) = 832
fstat(3, {st_mode=S_IFREG|0755, st_size=1838360, ...}) = 0
mmap(0x3080200000, 3664040, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x3080200000
mprotect(0x3080375000, 2097152, PROT_NONE) = 0
mmap(0x3080575000, 20480, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x175000) = 0x3080575000
mmap(0x308057a000, 18600, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x308057a000
close(3)                                = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f617c0bd000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f617c0bc000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f617c0bb000
arch_prctl(ARCH_SET_FS, 0x7f617c0bc700) = 0
mprotect(0x3080575000, 16384, PROT_READ) = 0
mprotect(0x308001e000, 4096, PROT_READ) = 0
munmap(0x7f617c0be000, 78932)           = 0
brk(0)                                  = 0x11d6000
brk(0x11f7000)                          = 0x11f7000
open("/dev/sda", O_RDONLY)              = 3
ioctl(3, BLKPG, 0x7fff757be870)         = -1 ENXIO (No such device or address)
ioctl(3, BLKPG, 0x7fff757be870)         = -1 ENXIO (No such device or address)
ioctl(3, BLKPG, 0x7fff757be870)         = -1 ENXIO (No such device or address)
ioctl(3, BLKPG, 0x7fff757be870)         = -1 ENXIO (No such device or address)
ioctl(3, BLKPG, 0x7fff757be870)         = -1 ENXIO (No such device or address)
ioctl(3, BLKPG, 0x7fff757be870)         = -1 ENXIO (No such device or address)
ioctl(3, BLKPG, 0x7fff757be870)         = -1 ENXIO (No such device or address)
ioctl(3, BLKPG, 0x7fff757be870)         = -1 ENXIO (No such device or address)
ioctl(3, BLKPG, 0x7fff757be870)         = -1 ENXIO (No such device or address)
ioctl(3, BLKPG, 0x7fff757be870)         = -1 ENXIO (No such device or address)
ioctl(3, BLKPG, 0x7fff757be870)         = -1 ENXIO (No such device or address)
[etc...]

I'll try to debug further, but if I had to guess, I'd say that upper == 0, since overriding it with --nr works.

Comment 1 Karel Zak 2010-05-13 20:12:51 UTC
Yes, it's already fixed upstream:
http://git.kernel.org/?p=utils/util-linux-ng/util-linux-ng.git;a=commit;h=c86dda7b36e3a6cfc63b9c03f7d275d715d35fd0

I'll fix it in F-13 later.

Comment 2 Fedora Update System 2010-05-19 11:55:22 UTC
util-linux-ng-2.17.2-5.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/util-linux-ng-2.17.2-5.fc13

Comment 4 Karel Zak 2010-05-19 12:17:59 UTC
Oh.. wrong window, please ignore the previous comment :-)

Comment 5 Fedora Update System 2010-05-28 17:58:02 UTC
util-linux-ng-2.17.2-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.