Bug 592071 - Installing rhel6 to KVM VM does not detect vm's network card
Installing rhel6 to KVM VM does not detect vm's network card
Status: CLOSED DUPLICATE of bug 609784
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity high
: rc
: ---
Assigned To: Radek Vykydal
Release Test Team
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-13 15:23 EDT by Steve Grubb
Modified: 2013-01-09 17:34 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-07 09:59:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (35.03 KB, text/plain)
2010-09-03 09:20 EDT, Steve Grubb
no flags Details
syslog (27.53 KB, text/plain)
2010-09-03 09:20 EDT, Steve Grubb
no flags Details
eth0 (73 bytes, text/plain)
2010-09-03 09:21 EDT, Steve Grubb
no flags Details

  None (edit)
Description Steve Grubb 2010-05-13 15:23:20 EDT
Description of problem:
Using beta1 and just tested on snap4, it is not detecting network cards when installing as a KVM virtual machine. I am using a fully updated F-12 machine and installing the DVD rhel6 server image through the Virtual Machine Manager. When I get to the screen that has a "Configure Network" button and click on it, it shows no wired cards. Looking at the view|Details menu item on the Virtual Machine shows a NIC with a MAC address.

After the newly installed vm reboots, networking is enabled but eth0 is not up. The install did make an ifcfg-eth0 file, but ONBOOT=no and BOOT_PROTO=dhcp is completely missing.

Version-Release number of selected component (if applicable):
whatever is in snap4.

How reproducible:
Always. Tried 4 different times.
Comment 1 Radek Vykydal 2010-05-14 04:52:02 EDT
This should be fixed in snap 5, you can see https://bugzilla.redhat.com/show_bug.cgi?id=520146#c45 for detailed info.

*** This bug has been marked as a duplicate of bug 520146 ***
Comment 2 Steve Grubb 2010-09-03 08:34:01 EDT
This bug still exists with the RC from Sept 1. Installation on F-13 KVM system leaves no network cards detected. This time instead of minimal install, I do a basic server install.
Comment 3 Radek Vykydal 2010-09-03 09:06:00 EDT
Can you please attach /var/log/anaconda.log, /var/log/anaconda.syslog from installed system?
Also either contents of /etc/sysconfig/network-scripts/ifcfg-eth* from installed system, or /tmp/ifcfg.log gathered at the end of installation will be helpful.
Comment 4 Steve Grubb 2010-09-03 09:20:17 EDT
Created attachment 442894 [details]
log
Comment 5 Steve Grubb 2010-09-03 09:20:51 EDT
Created attachment 442895 [details]
syslog
Comment 6 Steve Grubb 2010-09-03 09:21:19 EDT
Created attachment 442896 [details]
eth0
Comment 7 Radek Vykydal 2010-09-03 10:16:20 EDT
Just to make sure, the problem is that after clicking on "Configure Network", there is no eth0 in "Network Connections" dialog, right?
Comment 8 Dor Laor 2010-09-05 16:31:36 EDT
Is that unique for virtio NIC ? What happens when e1000 or rtl8139 are used?
Any idea what's the root-cause? If anaconda is the faulty one it shouldn't happen for VMs only
Comment 9 yanbing du 2010-09-06 04:40:00 EDT
Host F-13, guest rhel6-RC, do not meet the bug.
When click "Configure Network" button, the "Network Connections" dialog come out and can edit eth0 well with no problem.
Relative packages' version as following:
kernel-2.6.33.8-149.fc13.x86_64
libvirt-0.8.2-1.fc13.x86_64
qemu-kvm-0.12.5-1.fc13.x86_64
qemu-img-0.12.5-1.fc13.x86_64
python-virtinst-0.500.4-1.fc13.noarch
virt-manager-0.8.5-1.fc13.noarch

Move to VERIFIED.
Comment 10 Steve Grubb 2010-09-07 09:03:11 EDT
The problem is that no network is configured by default. Eth0 is there with the hw mac address, but its set to "no" for onboot. So, this means you cannot get into the machine after installing it except by the console. The series of dialogs also don't route me into anything where a network card might be configured, so maybe its not detecting one? Moving back out of VERIFIED because installing a system does not setup a network card that is usable from a guest.
Comment 11 Radek Vykydal 2010-09-07 09:24:38 EDT
(In reply to comment #10)
> The problem is that no network is configured by default.

This an issue different from that given in your bug Description, which is _detection_ of the card, and which is fixed. Your present problem is probably duplicate of bug 609784, see https://bugzilla.redhat.com/show_bug.cgi?id=609784#c17
Comment 12 Steve Grubb 2010-09-07 09:48:11 EDT
The description in comment #0 paragraph 2 is still the same. onboot="no" is what's written making networking unusable until a sysadmin intervenes. This is different than RHEL5 behavior. If this is an intentional design change, then I guess tech notes are appropriate.
Comment 13 David Cantrell 2010-09-07 09:59:31 EDT

*** This bug has been marked as a duplicate of bug 609784 ***

Note You need to log in before you can comment on or make changes to this bug.