Bug 59220 - Voodoo Banshee and Voodoo 3 extmod issue
Voodoo Banshee and Voodoo 3 extmod issue
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-02 13:22 EST by James Pattie
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-02 13:22:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Pattie 2002-02-02 13:22:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.7) Gecko/20011226

Description of problem:
When extmod is Loaded for a Voodoo Banshee AGP or Voodoo3 3000 AGP, all versions
of X 4.1.0 and 4.2.0 crash when trying to switch video resolutions.  This can be
triggered by doing the Ctrl-Alt-+/- sequence or having a video game try to go
into full screen mode.  If I limit the resolutions that X will work with to a
single mode (800x600 for example) then the games can go full screen and
Ctrl-Alt-+/- works as we have no other mode to switch to.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Have a Voodoo Banshee or Voodoo3 AGP card (not tested on PCI versions yet)
2.Load "extmod" (in XF86Config-4)
3.Try to switch video modes or run a OpenGL game in full screen.
	

Actual Results:  X flips back to the resolution I was last in (1600x1200) and
then restarts itself.  This corrupts all text consoles (vt's) and puts a image
of what was last on the screen on them.  X comes back ok, but on the next
available vt.  I have X running on vt 2 so it toggles between vt 3 and vt 2 each
time it crashes.

Expected Results:  X should have gone to the next/previous resolution or gone
full screen.

Additional info:

I have tested this only on AGP video cards.  This was fixed for one of the
releases of X 4.0.3 but was broken in the 4.1.0 release.

I am currently rebuilding the X 4.2.0 srpms from rawhide on my 7.1 and 7.2 boxes
for the testing.
Comment 1 Mike A. Harris 2002-02-02 13:33:47 EST
This is not a bug.  You are running in a resolution that is way
beyond the capabilities of your hardware in XFree86.  When using
16Mb Voodoo 3 or Banshee cards, you must have X configured in
16bit depth, with a maximum resolution of 1024x768.  For example:


DefaultDepth 16
Subsection "Display"
    Depth 16
    Modes "1024x768" "800x600" "640x480"
EndSubSection

The above configures XFree86 to start up in 1024x768 which is the
highest resolution that is supported by DRI for this hardware.

Comment 2 James Pattie 2002-02-02 22:15:19 EST
Thanks for the info.  I just did a pretty thorough check of man pages and the
DRI web page and there is no mention that it only supports upto 1024x768 in full
screen mode.

I dropped my modes to only have 1024x768, 800x600 and 640x480 and it works in
switching modes, etc.  This is a pain in the but when you are used to working in
1600x1200.

You might want to mention this somewhere that people can see since I'm sure I'm
not the only one who has had this problem.

Note You need to log in before you can comment on or make changes to this bug.