Bug 592225 - DUP image failed to load: error: Unable to open /usr/lib/rpm/rpmrc for reading
Summary: DUP image failed to load: error: Unable to open /usr/lib/rpm/rpmrc for reading
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 6.0
Hardware: All Linux
high
high
Target Milestone: beta
: ---
Assignee: Martin Sivák
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 575298 591369
TreeView+ depends on / blocked
 
Reported: 2010-05-14 09:57 UTC by Qian Cai
Modified: 2010-07-02 20:49 UTC (History)
4 users (show)

Fixed In Version: anaconda-13.21.42-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 20:49:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt guest xml (2.36 KB, application/xml)
2010-05-14 09:57 UTC, Qian Cai
no flags Details

Description Qian Cai 2010-05-14 09:57:10 UTC
Created attachment 413994 [details]
virt guest xml

Description of problem:
When dd=http://10.66.65.177/dd.iso, the DUD failed to load,

Welcome to Red Hat Enterprise Linux for x86_64







                                                                                
                   ┌──────────────┤ Loading ├───────────────┐                   
                   │                                        │                   
                   │ error: Unable to open /usr/lib/rpm/rpmrc for reading: No such file or directory.
                   │                                        │                                        error: no dbpath has been set
                   └────────────────────────────────────────┘                                                                     error: cannot open Packages database in                                                                    
             error: Unable to open /usr/lib/rpm/rpmrc for reading: No such file or directory.
                                                                                             error: no dbpath has been set

Version-Release number of selected component (if applicable):
RHEL6.0-20100512.0
anaconda-13.21.39-1.el6
kernel-2.6.32-25.el6

How reproducible:
always

Steps to Reproduce:
1. rebuild the example DUD against -25.el6 kernel
2. download pxeboot vmlinuz and initrd.img
3. modify the virt guest xml to boot from the above file, and setup "dd" parameter pointed to the http location with the DUD image
4. boot the system
  
Actual results:
error messages; anaconda stops working

Expected results:
Successfully load the driver image.

Comment 1 Qian Cai 2010-05-14 10:03:15 UTC
Same for FTP.

Comment 2 Qian Cai 2010-05-14 10:13:31 UTC
From the VGA console, I can see lots of those messages,
ERROR: /tmp/DD-0/kmod-sym53c8xx-2.2.3.rhtest600512-1.el6.x86_64.rpm Too many open files.

Comment 3 Qian Cai 2010-05-14 10:14:02 UTC
NFS has the same problem too.

Comment 4 Martin Sivák 2010-05-17 12:16:03 UTC
Can you somehow get me the anaconda.log from around when this problem happened please?

Part of this problem is missing /usr/lib/rpm/rpmrc, but that is not critical as we tested with rpm maintainer.

The too many open files error is much more serious and probably causes the rest. I recently fixed similar error in loader, but to identify the problem spot I need more information.

Comment 5 Martin Sivák 2010-05-17 13:08:04 UTC
OK, I finally reproduced it and found the leak, this should be fixed in anaconda anaconda-13.21.41-1.

Comment 7 Martin Sivák 2010-05-18 07:37:45 UTC
Sorry I overlooked a tag, I ment anaconda-13.21.42-1.

Comment 8 Jon Masters 2010-05-18 16:54:24 UTC
Thanks Martin.

Comment 9 Qian Cai 2010-05-20 05:12:43 UTC
Martin, looks like I am running into another issue (error: no dbpath has been set) with anaconda-13.21.42-1,
Welcome to Red Hat Enterprise Linux for x86_64

                    ┌────────┤ Choose a Language ├────────┐
                    │                                     │
                    │ What language would you like to use │
                    │ during the installation process?    │
                    │                                     │
                    │      Catalan                ↑       │
                    │      Chinese(Simplified)    ▒       │                     
                    │      Chinese(Traditional)   ▮       │                     
                    │      Croatian               ▒       │                     
                    │      Czech                  ▒       │                     
                    │      Danish                 ▒       │                     tabase in 
                    │      Dutch                  ▒       │                               error: no dbpath has been set
                    │ectingEnglish                ↓       │                                                            error: cannot open Packages database i                    │                  waiting for hardwar│ to initialize...
                    │               ┌────┐                │
                    │               │ OK │                │
                    │               └────┘                │
                    │                                     │
                    │                                     │
                    └─────────────────────────────────────┘

  <Tab>/<Alt-Tab> between elements  | <Space> selects | <F12> next screen

Comment 12 releng-rhel@redhat.com 2010-07-02 20:49:32 UTC
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.