Bug 592274 - [abrt] crash in liferea-1:1.6.2-2.fc12: raise: Process /usr/bin/liferea was killed by signal 6 (SIGABRT)
Summary: [abrt] crash in liferea-1:1.6.2-2.fc12: raise: Process /usr/bin/liferea was k...
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: liferea   
(Show other bugs)
Version: 12
Hardware: i686 Linux
low
medium
Target Milestone: ---
Assignee: Steven M. Parrish
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:831fb39dcc48c5e9dd3869fdf60...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-14 12:07 UTC by Laurent Forthomme
Modified: 2010-08-18 16:49 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-18 16:49:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (29.90 KB, text/plain)
2010-05-14 12:07 UTC, Laurent Forthomme
no flags Details
plugin error message (10.40 KB, image/png)
2010-05-27 05:58 UTC, Mircea Sava
no flags Details

Description Laurent Forthomme 2010-05-14 12:07:54 UTC
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: liferea
component: liferea
crash_function: raise
executable: /usr/bin/liferea
global_uuid: 831fb39dcc48c5e9dd3869fdf606c7f91f51fa63
kernel: 2.6.32.11-99.fc12.i686
package: liferea-1:1.6.2-2.fc12
rating: 4
reason: Process /usr/bin/liferea was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)

Comment 1 Laurent Forthomme 2010-05-14 12:07:59 UTC
Created attachment 414034 [details]
File: backtrace

Comment 2 Paul 2010-05-16 10:25:31 UTC
Package: liferea-1:1.6.2-2.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1.add this feed to liferea: http://feeds.feedburner.com/uclick/garfield
2.under advanced properties, check auto-load (firefox in my case)
3.click on an item in the garfield feed


Comment
-----
liferea crashes when auto-loading feed items (the garfield feed is just an example, it happens with others aswell)

Comment 3 Steve 2010-05-16 19:14:52 UTC
Package: liferea-1:1.6.2-2.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


Comment
-----
there was some kind of a plugin error..

Comment 4 Dwayne Bailey 2010-05-17 17:01:03 UTC
Package: liferea-1:1.6.2-2.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


Comment
-----
Not sure what was heppening

Comment 5 Steve 2010-05-18 12:54:02 UTC
Package: liferea-1:1.6.2-2.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


Comment
-----
i have no idea

Comment 6 Tom Georgoulias 2010-05-19 23:27:58 UTC
Here's the error I see when I run liferea from terminal and click on a post that causes a crash:

$ liferea
set zoom: 1.00
** (liferea:3653): DEBUG: NP_Initialize
** (liferea:3653): DEBUG: NP_Initialize succeeded
/builddir/build/BUILD/icedtea6-1.8/plugin/icedteanp/IcedTeaNPPlugin.cc:1508: thread 0x86fa028: Error: Failed to spawn applet viewer: Failed to execute child process "/etc/alternatives/../../bin/java" (No such file or directory)

Comment 7 Tom Georgoulias 2010-05-20 00:50:30 UTC
Reverting to the previous version of java has fixed the problem.  I got these RPMs from koji and installed them, then verified by going back to the blog postings that caused the crashes.  Liferea held up just fine.

http://koji.fedoraproject.org/koji/buildinfo?buildID=165605

java-1.6.0-openjdk-plugin-1.6.0.0-37.b17.fc12.i686.rpm
java-1.6.0-openjdk-1.6.0.0-37.b17.fc12.i686.rpm

Comment 8 Mircea Sava 2010-05-27 05:58:09 UTC
Created attachment 417128 [details]
plugin error message

I don't know if this helps but I noticed this problem immediately after I set the "Enable browser plugins" option "on"

Comment 9 Laurent Forthomme 2010-05-30 09:25:22 UTC
Package: liferea-1:1.6.2-2.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1.Read a RSS news
2.
3.

Comment 10 Steven M. Parrish 2010-07-13 22:26:50 UTC
Liferea 1.6.4 has been pushed to stable.  Please upgrade to this latest version and see if it corrects this issue.  If there is no update to this bug within 30 days will close as WORKSFORME.

Thanks

Comment 11 Paul 2010-07-14 06:17:36 UTC
Works for me,  it's not crashing anymore.


Note You need to log in before you can comment on or make changes to this bug.