Bug 592339 - PartitionException: Attempting to remove a partition that is not owned by any disk.
Summary: PartitionException: Attempting to remove a partition that is not owned by any...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: David Lehman
QA Contact: Release Test Team
URL:
Whiteboard: anaconda_trace_hash:14ff6220be7288e83...
Keywords:
: 610749 (view as bug list)
Depends On: 580088
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-14 15:30 UTC by David Lehman
Modified: 2010-07-02 20:49 UTC (History)
2 users (show)

Fixed In Version: anaconda-13.21.44-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 580088
Environment:
Last Closed: 2010-07-02 20:49:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Lehman 2010-05-14 15:30:17 UTC
+++ This bug was initially created as a clone of Bug #580088 +++

The following was filed automatically by anaconda:
anaconda 13.37.2 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/parted/disk.py", line 269, in removePartition
    if self.__disk.remove_partition(partition.getPedPartition()):
  File "/usr/lib/python2.6/site-packages/parted/decorators.py", line 31, in localeC
    ret = fn(*args, **kwds)
  File "<string>", line 2, in removePartition
  File "/usr/lib/anaconda/storage/formats/disklabel.py", line 276, in removePartition
    self.partedDisk.removePartition(partition)
  File "/usr/lib/anaconda/storage/devices.py", line 1342, in destroy
    self.disk.format.removePartition(self.partedPartition)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 218, in execute
    self.device.destroy()
  File "/usr/lib/anaconda/storage/devicetree.py", line 677, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 290, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 109, in turnOnFilesystems
    anaconda.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 659, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 1188, in <module>
    anaconda.intf.run(anaconda)
PartitionException: Attempting to remove a partition that is not owned by any disk.

--- Additional comment from jlaska@redhat.com on 2010-04-07 09:16:34 EDT ---

Created an attachment (id=404949)
Attached traceback automatically from anaconda.

--- Additional comment from clumens@redhat.com on 2010-05-01 20:42:15 EDT ---

*** Bug 587835 has been marked as a duplicate of this bug. ***

--- Additional comment from dlehman@redhat.com on 2010-05-03 16:27:34 EDT ---

We remove a partition, then the disklabel commit fails because the partition is in use. We do not put the partition back while in the exception handler, and then we end up trying to remove it again only to find that there is nothing there to remove. What we need to do is add the partition back to the parted.Disk instance when the commit fails ala commit b3337f7d91c5d.

Comment 2 RHEL Product and Program Management 2010-05-14 15:54:47 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 David Cantrell 2010-05-14 22:37:34 UTC
Can we get a qa_ack for this?  Issued discovered and fixed during F-13 development, affects RHEL-6 too.

Comment 6 Alexander Todorov 2010-07-02 11:11:10 UTC
*** Bug 610749 has been marked as a duplicate of this bug. ***

Comment 7 Alexander Todorov 2010-07-02 11:21:16 UTC
Testing with snapshot #7, anaconda 13.21.56 and the steps to reproduce from the duplicate bug:
https://bugzilla.redhat.com/show_bug.cgi?id=610749#c2

Didn't result in traceback. I was able to delete old partitions and create new ones and write changes to disk. Anaconda was able to proceed to package selection. Install completed and the system was able to boot. 

Moving to VERIFIED.

Comment 8 releng-rhel@redhat.com 2010-07-02 20:49:39 UTC
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.