Bug 59235 - mpg321 can't open ESD
mpg321 can't open ESD
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: mpg321 (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-03 04:11 EST by CoreDump
Modified: 2014-03-16 22:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-05 13:04:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description CoreDump 2002-02-03 04:11:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.17-0.1custom i686)

Description of problem:
Well, the new mpg321 has been changed to use esd.
Now it can't work at all.
If i start it first, (without starting X) it says:
Error opening libao ESD driver (is ESD running ?)
esd wasn't running that time, but X can start it on its own,
so I started X.
mpg321 still responds the same.
Therefore the original bug report (they can't play sound concurrently
is still up, topped with the fact mpg321 can't play sound if used alone at all).



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start mpg321 after reboot

or 

1. start X
2. start mpg321

	

Additional info:
Comment 1 Bill Nottingham 2002-02-04 15:38:13 EST
It works for me as long as nothing else is holding the sound card open.

What sort of sound card do you have? Are you certain nothing else
(arts, for example) is using the sound card?
Comment 2 CoreDump 2002-02-05 13:04:17 EST
I have a c-media soundcard (integrated on the motherboard).
The driver is compiled in the kernel.
Installed packages:
esound-0.2.22-5
XFree86-4.1.0-12
enlightenment-0.16.4-11

arts is NOT installed

I start X manually by startx which loads esd, esd is not in memory after bootup.
mpg321 can't open ESD in these cases:
1. I start it right after logging on (from a character console)
2. I start esd just as startx would start it
3. I start X

enlightenment correctly emits sound effects etc.

My original problem was that mpg321 didn't play sound concurrently with
enlightenment, mpg321 was upgraded partly based on that bugrep #51996 (its
compile time options were set to use ESD).
But it played sound when i exited from X or disabled sound in enlightenment.
Now it can't play sound in any case.

Comment 3 CoreDump 2002-02-10 07:54:03 EST
Ok, updating to libao-0.8.2-2 fixed the problem.
Comment 4 Pekka Savola 2002-05-22 04:24:16 EDT
I experienced the same with RHL73:

$ rpm -q libao mpg321
libao-0.8.2-2
mpg321-0.2.9-3

I wasn't running anything else.  When I started xmms, played an mp3, and exited
-- mpg321 started working too.

Note You need to log in before you can comment on or make changes to this bug.