Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 592367 - usermode is needed by (installed) eject-2.1.5-18.fc13.x86_64
Summary: usermode is needed by (installed) eject-2.1.5-18.fc13.x86_64
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: eject
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kamil Dudka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-14 16:27 UTC by Bill Nottingham
Modified: 2014-03-17 03:23 UTC (History)
2 users (show)

Fixed In Version: eject-2.1.5-19.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-25 14:24:29 UTC
Type: ---


Attachments (Terms of Use)

Description Bill Nottingham 2010-05-14 16:27:00 UTC
Description of problem:

Isn't this already handled by device ACLs?

Version-Release number of selected component (if applicable):

2.1.5-18.fc13

How reproducible:

100%

Steps to Reproduce:
1. Attempt to remove usermode

Comment 1 Kamil Dudka 2010-05-14 16:38:15 UTC
It was added recently due to rpmlint warning as requested in the merge review:

bug #225720 comment #c7

Any idea why rpmlint was complaining about that?  Is it a bug of rpmlint instead?

Comment 2 Kamil Dudka 2010-05-14 16:38:44 UTC
bug #225720 comment #7

Comment 3 Bill Nottingham 2010-05-17 15:19:05 UTC
The rpmlint error is there because it included the pam configuration for usermode, and a symlink for usermode. I'm wondering why it needs any of those things.

Comment 4 Kamil Dudka 2010-05-25 14:24:29 UTC
I've dropped the use of consolehelper completely and made a new build for rawhide:

eject-2.1.5-19.fc14

We'll see if it breaks something or not.


Note You need to log in before you can comment on or make changes to this bug.