Bug 592376 - [abrt] crash in python-twisted-core-8.2.0-6.fc12: fedora.py:57:get_connection_args:IndexError: list index out of range
Summary: [abrt] crash in python-twisted-core-8.2.0-6.fc12: fedora.py:57:get_connection...
Keywords:
Status: CLOSED DUPLICATE of bug 544986
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jiri Moskovcak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:492cbaf4
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-14 17:22 UTC by Marcel
Modified: 2015-02-01 22:52 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-24 10:41:04 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.13 KB, text/plain)
2010-05-14 17:22 UTC, Marcel
no flags Details

Description Marcel 2010-05-14 17:22:44 UTC
abrt 1.0.9 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python /usr/bin/twistd -r gtk2 --pidfile /tmp/vmc.pid -noy /usr/share/vodafone-mobile-connect/gtk-tap.py -l /dev/null
component: python-twisted-core
executable: /usr/bin/twistd
kernel: 2.6.32.12-115.fc12.x86_64
package: python-twisted-core-8.2.0-6.fc12
reason: fedora.py:57:get_connection_args:IndexError: list index out of range
release: Fedora release 12 (Constantine)

backtrace
-----
fedora.py:57:get_connection_args:IndexError: list index out of range

Traceback (most recent call last):
  File "/usr/share/vodafone-mobile-connect/vmc/gtk/controllers/application.py", line 674, in on_connect_button_toggled
    d = self.model.connect_internet()
  File "/usr/share/vodafone-mobile-connect/vmc/gtk/models/application.py", line 113, in connect_internet
    return self.connsm.connect()
  File "/usr/share/vodafone-mobile-connect/vmc/common/statem/connection.py", line 195, in connect
    return self.do_next()
  File "/usr/share/vodafone-mobile-connect/vmc/common/statem/connection.py", line 244, in do_next
    d = self.dialer.connect()
  File "/usr/share/vodafone-mobile-connect/vmc/common/dialers/wvdial.py", line 308, in connect
    args = osobj.get_connection_args(self)
  File "/home/bouchindhommeh/.vmc2/plugins/os/fedora.py", line 57, in get_connection_args
    gksudo_path = which(gksudo_name)[0]
IndexError: list index out of range

Local variables in innermost frame:
dialer: <vmc.common.dialers.wvdial.WvdialDialer object at 0x353ee10>
gksudo_name: 'gksu'
self: <vmc.common.plugins.fedora.FedoraBasedDistro object at 0x3545190>

How to reproduce
-----
1. Use vodafone mobil connect
2.
3.

Comment 1 Marcel 2010-05-14 17:22:47 UTC
Created attachment 414119 [details]
File: backtrace

Comment 2 Thomas Vander Stichele 2010-05-24 10:30:11 UTC
This is an application bug and I have no idea why abrt points the finger at
python-twisted-core... So that's a bug in abrt to fix.

Comment 3 Jiri Moskovcak 2010-05-24 10:41:04 UTC

*** This bug has been marked as a duplicate of bug 544986 ***


Note You need to log in before you can comment on or make changes to this bug.