Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 592515 - mesa-dri-drivers-experimental nv30 (fx5500) compiz garbled output
mesa-dri-drivers-experimental nv30 (fx5500) compiz garbled output
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
: Desktop, HardwareEnablement
: 591918 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-14 23:53 EDT by Sam H
Modified: 2010-11-01 23:46 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-01 23:46:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of desktop with compiz (582.06 KB, image/png)
2010-05-14 23:53 EDT, Sam H
no flags Details
GnomeShell screenshot (rawhide) (18.53 KB, image/png)
2010-06-13 19:01 EDT, Javier Jardón
no flags Details

  None (edit)
Description Sam H 2010-05-14 23:53:40 EDT
Created attachment 414205 [details]
screenshot of desktop with compiz

Description of problem:
With compiz enabled using mesa-dri-drivers-experimental with a nVidia Corporation NV34 [GeForce FX 5500] (rev a1) the display is jarbled.

Version-Release number of selected component (if applicable):
mesa-dri-drivers-experimental-7.8.1-6.fc13.i686

How reproducible:
I have been able to reproduce this every time I try to enable desktop effects.

Steps to Reproduce:
1.Go to System -> Preferences -> Desktop Effects.
2.Enable compiz.
3. Enjoy ;)
  
Actual results:
Display is garbled. The basic outline can be seen but that's about it.

Expected results:
Should be able to see everything with some nice eyecandy.

Additional info:
OpenGL vendor string: nouveau
OpenGL renderer string: Gallium 0.4 on NV34
OpenGL version string: 2.0 Mesa 7.8.1
OpenGL shading language version string: 1.20
direct rendering: Yes

Screen-shot attached.
Comment 1 Javier Jardón 2010-05-15 11:17:51 EDT
*** Bug 591918 has been marked as a duplicate of this bug. ***
Comment 2 Javier Jardón 2010-05-15 11:19:18 EDT
Same here with this card:
01:00.0 VGA compatible controller: nVidia Corporation NV36.4 [GeForce FX 5700VE] (rev a1)
Comment 3 Sam H 2010-05-20 18:52:24 EDT
From what I can tell opengl is completely broken on these cards using the mesa-dri-experimental-drivers (I have installed all updates and it is still the same). If anymore information is required I will try my best to obtain it.
Comment 4 Javier Jardón 2010-05-20 19:18:29 EDT
No, at least in my case (GeForce FX 5700VE) OpenGL is not broken.

I can play neverball, xmoto, supertuxkart nad more 3D games without problems.
Comment 5 Sam H 2010-05-25 00:53:29 EDT
I can't reproduce the problem I was having in relation to comment 3 after a reboot. Original bug still stands.
Comment 6 Gabriel Gomez 2010-05-28 14:16:11 EDT
Compiz doesn't work for me. I get the same result with this card:

01:00.0 VGA compatible controller [0300]: nVidia Corporation NV34 [GeForce FX 5200] [10de:0322] (rev a1)
Comment 7 KL 2010-05-29 06:57:01 EDT
Same error applies to NV38 (Quadro FX1300 on Dell Precision 670) - screen is garbled as soon as compiz is enabled.

05:00.0 VGA compatible controller: nVidia Corporation NV38GL [Quadro FX 1300] (rev a2)

OpenGL vendor string: nouveau
OpenGL renderer string: Gallium 0.4 on NV35
OpenGL version string: 2.0 Mesa 7.8.1
OpenGL shading language version string: 1.20

glxgears works fine (~2000 frames) but shows wrong GL_RENDERER:
GL_RENDERER   = Gallium 0.4 on NV35
GL_VERSION    = 2.0 Mesa 7.8.1
GL_VENDOR     = nouveau
Comment 8 Trevor Mettam 2010-06-10 06:30:00 EDT
Same result here:

01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5500] (rev a1)
direct rendering: Yes
OpenGL vendor string: nouveau
OpenGL renderer string: Gallium 0.4 on NV34
OpenGL version string: 2.0 Mesa 7.8.1
OpenGL shading language version string: 1.20

* Garbled output on: Compiz; GNOME Shell; Armacycles AD; Globulation 2; BosWars; Astromenace

* Glaxium works fine for a bit then cuts to black.

* Incorrect lighting on ball and coins in Neverball/Neverputt, otherwise works fine.

* Flickering frame buffers on D1X (Descent)
Comment 9 Trevor Mettam 2010-06-10 09:35:32 EDT
...also

* Penumbra Demos (Overture and Black Plague) crash
Comment 10 Javier Jardón 2010-06-13 19:01:20 EDT
Created attachment 423705 [details]
GnomeShell screenshot (rawhide)

Rawhide here.

The sitouation was improved a bit with the latest driver update:

Name        : mesa-dri-drivers-experimental
Arch        : x86_64
Version     : 7.9
Release     : 0.2.fc14
Comment 11 Trevor Mettam 2010-06-16 07:49:01 EDT
Tried another couple of 3D game engines...

* Q3A (Quake III Arena, Urban Terror, World of Padman) work fine, albeit slow, except for WoP which hangs the machine when you try to start a game/demo.

* Darkplaces (Quake, Nexuiz) crashes.
Comment 12 Eddie Lania 2010-06-21 07:35:43 EDT
Having exactly the same problems.

VGA compatible controller: nVidia Corporation NV34GL [Quadro FX 500/600 PCI] (rev a1) (prog-if 00 [VGA controller])
Comment 13 Michael Setzer II 2010-07-09 12:36:04 EDT
Just installed Fedora 13 with Nvidia FX5500 PCI card since machine has not AGP slot, and see the same garbled screen when selecting the Desktop effects.
Comment 14 Trevor Mettam 2010-08-15 23:44:07 EDT
Legacy propriety nVidia NV34 drivers for Xorg 1.8 under Fedora 13 are now available at RPMFusion.

repo:     rpmfusion-nonfree-updates-testing
package:  kmod-nvidia-173xx (meta-package, will install dependencies)

Note: requires Kernel 2.6.34.
Comment 15 Julian Sikorski 2010-09-29 18:55:52 EDT
I no longer use this hardware.
Comment 16 Ben Skeggs 2010-11-01 23:46:02 EDT
This won't be fixed in F13.  Please update to F14 and file a new bug if the problem still persists.

Note You need to log in before you can comment on or make changes to this bug.