Bug 59263 - core dump on logout
Summary: core dump on logout
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 61901
TreeView+ depends on / blocked
 
Reported: 2002-02-04 08:46 UTC by Tim Waugh
Modified: 2007-04-18 16:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-28 08:57:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim Waugh 2002-02-04 08:46:40 UTC
Description of Problem:
Whenever I log out of KDE I get a nice big core dump in my home directory.

Version-Release number of selected component (if applicable):
kdebase-3.0.0-0.cvs20020129.1
kdelibs-3.0.0-0.cvs20020128.3
qt-3.0.2-0.cvs20020118.2

How Reproducible:
100%

Steps to Reproduce:
1. Logout

Actual Results:
Core file produced.

Expected Results:
No core.

Additional Information:
It looks like this:

#0  0x4003c9ed in DCOPClient::detach() () from /usr/lib/libDCOP.so.4
#1  0x4130b928 in crashHandler(int) () from /usr/lib/kdesktop.so
#2  0x40e147fc in pthread_sighandler () from /lib/i686/libpthread.so.0
#3  <signal handler called>
#4  0x40f9d26d in chunk_free () from /lib/i686/libc.so.6
#5  0x40f9ea0f in free () from /lib/i686/libc.so.6
#6  0x40e931c3 in operator delete(void*) (ptr=0x50)
    at ../../../../libstdc++-v3/libsupc++/del_op.cc:39
#7  0x40afd842 in QGDict::clear() () from /usr/lib/qt3/lib/libqt-mt.so.3
#8  0x40b9ef7d in QMemberDict::~QMemberDict() ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#9  0x408ace28 in QMetaObject::~QMetaObject() ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#10 0x408ae448 in QMetaObjectCleanUp::~QMetaObjectCleanUp() ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#11 0x41275f01 in __static_initialization_and_destruction_0(int, int) ()
   from /usr/lib/libkonq.so.4
#12 0x412763ba in _GLOBAL__D__ZN13KonqPopupMenu12ProtocolInfoC2Ev ()
   from /usr/lib/libkonq.so.4
#13 0x412313fd in __do_global_dtors_aux () from /usr/lib/libkonq.so.4
#14 0x4127dda9 in _fini () from /usr/lib/libkonq.so.4
#15 0x4001005e in _dl_fini () from /lib/ld-linux.so.2
#16 0x40f50850 in exit () from /lib/i686/libc.so.6
	
(By the way, the fact that threaded coredumps are enabled now means that this is
more of a problem than it always has been.)

Comment 1 Bernhard Rosenkraenzer 2002-04-03 10:52:25 UTC
Not reproducable.


Note You need to log in before you can comment on or make changes to this bug.