Bug 592652 - SELinux is preventing /usr/bin/cpufreq-selector "getattr" access on /usr/share/locale/locale.alias.
Summary: SELinux is preventing /usr/bin/cpufreq-selector "getattr" access on /usr...
Keywords:
Status: CLOSED DUPLICATE of bug 592651
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:0bbed2ece53...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-15 23:53 UTC by Gene Snider
Modified: 2010-05-24 14:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-17 13:10:03 UTC
Type: ---


Attachments (Terms of Use)

Description Gene Snider 2010-05-15 23:53:43 UTC
Summary:

SELinux is preventing /usr/bin/cpufreq-selector "getattr" access on
/usr/share/locale/locale.alias.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by cpufreq-selecto. It is not expected that this
access is required by cpufreq-selecto and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:cpufreqselector_t:s0-s0:c0.c1023
Target Context                system_u:object_r:locale_t:s0
Target Objects                /usr/share/locale/locale.alias [ file ]
Source                        cpufreq-selecto
Source Path                   /usr/bin/cpufreq-selector
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gnome-applets-2.30.0-1.fc13
Target RPM Packages           glibc-common-2.12-1
Policy RPM                    selinux-policy-3.7.19-15.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.4-95.fc13.x86_64 #1 SMP Thu
                              May 13 05:16:23 UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Sat 15 May 2010 04:51:40 PM PDT
Last Seen                     Sat 15 May 2010 04:51:40 PM PDT
Local ID                      08d7c0bf-d514-426e-ab0c-2543fde089a5
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1273967500.706:21213): avc:  denied  { getattr } for  pid=6206 comm="cpufreq-selecto" path="/usr/share/locale/locale.alias" dev=dm-0 ino=6825 scontext=system_u:system_r:cpufreqselector_t:s0-s0:c0.c1023 tcontext=system_u:object_r:locale_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1273967500.706:21213): arch=c000003e syscall=5 success=yes exit=0 a0=3 a1=7ffffe4b67a0 a2=7ffffe4b67a0 a3=0 items=0 ppid=6205 pid=6206 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="cpufreq-selecto" exe="/usr/bin/cpufreq-selector" subj=system_u:system_r:cpufreqselector_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,cpufreq-selecto,cpufreqselector_t,locale_t,file,getattr
audit2allow suggests:

#============= cpufreqselector_t ==============
allow cpufreqselector_t locale_t:file getattr;

Comment 1 Daniel Walsh 2010-05-17 13:10:03 UTC

*** This bug has been marked as a duplicate of bug 592651 ***


Note You need to log in before you can comment on or make changes to this bug.