Bug 59269 - konqueror crash
konqueror crash
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: kdebase (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-04 06:15 EST by Tim Waugh
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-04 06:15:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2002-02-04 06:15:28 EST
Description of Problem:
While logging out of www.pay-as-you-host.com konqueror crashes.

Version-Release number of selected component (if applicable):
kdebase-3.0.0-0.cvs20020129.1
kdelibs-3.0.0-0.cvs20020128.3

How Reproducible:
100%

Steps to Reproduce:
1. Go to www.pay-as-you-host.com and get an account.
2. Log on to www.pay-as-you-host.com
3. Log out of it.

Actual Results:
Crash.

Expected Results:
No crash. :-)

Additional Information:
(no debugging symbols found)...[New Thread 1024 (LWP 29531)]
0x40fdcff9 in wait4 () from /lib/i686/libc.so.6
#0  0x40fdcff9 in wait4 () from /lib/i686/libc.so.6
#1  0x4106b690 in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x40e16483 in waitpid () from /lib/i686/libpthread.so.0
#3  0x40608aa9 in KCrash::defaultCrashHandler(int) ()
   from /usr/lib/libkdecore.so.4
#4  0x40e147fc in pthread_sighandler () from /lib/i686/libpthread.so.0
#5  <signal handler called>
#6  0x408b8457 in QObject::inherits(char const*) const ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#7  0x412d84d5 in KonqMainWindow::updateViewActions() ()
   from /usr/lib/konqueror.so
#8  0x412ce53f in KonqMainWindow::viewsChanged() () from /usr/lib/konqueror.so
#9  0x412ce4a5 in KonqMainWindow::viewCountChanged() ()
   from /usr/lib/konqueror.so
#10 0x412ce179 in KonqMainWindow::removeChildView(KonqView*) ()
   from /usr/lib/konqueror.so
#11 0x412ed17a in KonqViewManager::removePart(KParts::Part*) ()
   from /usr/lib/konqueror.so
#12 0x400810be in KParts::PartManager::slotObjectDestroyed() ()
   from /usr/lib/libkparts.so.2
#13 0x4008167c in KParts::PartManager::qt_invoke(int, QUObject*) ()
   from /usr/lib/libkparts.so.2
#14 0x412f1583 in KonqViewManager::qt_invoke(int, QUObject*) ()
   from /usr/lib/konqueror.so
#15 0x408ba4c0 in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#16 0x408ba3ef in QObject::activate_signal(int) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0x40b5eadb in QObject::destroyed() () from /usr/lib/qt3/lib/libqt-mt.so.3
#18 0x408b7bae in QObject::~QObject() () from /usr/lib/qt3/lib/libqt-mt.so.3
#19 0x4007a911 in KParts::Part::~Part() () from /usr/lib/libkparts.so.2
#20 0x4007b0e7 in KParts::ReadOnlyPart::~ReadOnlyPart() ()
   from /usr/lib/libkparts.so.2
#21 0x4155d16d in KHTMLPart::~KHTMLPart() () from /usr/lib/libkhtml.so.4
#22 0x41889787 in KJS::WindowQObject::timeoutClose() ()
   from /usr/lib/kde3/kjs_html.so
#23 0x4188cdb8 in KJS::WindowQObject::qt_invoke(int, QUObject*) ()
   from /usr/lib/kde3/kjs_html.so
#24 0x408ba51b in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#25 0x40b5fed2 in QSignal::signal(QVariant const&) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0x408d3078 in QSignal::activate() () from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0x408da143 in QSingleShotTimer::event(QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#28 0x4086bce4 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0x4086b5c3 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0x40599bc6 in KApplication::notify(QObject*, QEvent*) ()
#31 0x40814eab in qt_activate_timers() () from /usr/lib/qt3/lib/libqt-mt.so.3
#32 0x4081297e in QApplication::processNextEvent(bool) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0x4086d2c0 in QApplication::enter_loop() ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0x408125bd in QApplication::exec() () from /usr/lib/qt3/lib/libqt-mt.so.3
#35 0x412befd7 in main () from /usr/lib/konqueror.so
#36 0x0804d10e in strcpy ()
#37 0x0804de4a in strcpy ()
#38 0x0804e389 in strcpy ()
#39 0x0804f0f0 in strcpy ()
#40 0x40f3c108 in __libc_start_main () from /lib/i686/libc.so.6
Comment 1 Tim Waugh 2002-03-15 13:58:03 EST
This seems to be fixed in kdebase-3.0.0-0.cvs20020314.1.

Note You need to log in before you can comment on or make changes to this bug.