Bug 592697 - Ability to organize VMs/connections in groups
Summary: Ability to organize VMs/connections in groups
Status: CLOSED WONTFIX
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-manager   
(Show other bugs)
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Cole Robinson
QA Contact:
URL:
Whiteboard:
Keywords:
: 700407 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-16 11:06 UTC by Jo-Erlend Schinstad
Modified: 2012-01-25 02:05 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-25 02:05:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jo-Erlend Schinstad 2010-05-16 11:06:23 UTC
Description of problem:
Sometimes, I virtualize two or more networks at the same time, on the same hypervisor. However, in the virt-manager GUI, it isn't very easy to see the relationship between the VMs. It would be very nice if we could group the virtual machines. We could then collapse the list of VMs that are irrelevant to us now, and get a much better overview of the virtual network we're currently working on. 

I also have a lot of prototype machines which I only use for cloning. It would be nice to get them out of the way when I'm not using them. 

If we could group them across hypervisors, that would be great. The hypervisor connections get their own collapsible group now. It would be nice if we could just create such a group, give it a name, then drag and drop the virtual machines into those groups. This shouldn't affect the hypervisor group in any way, of course. It would only be a convenience.

Version-Release number of selected component (if applicable):
0.8.2

Comment 1 Cole Robinson 2011-07-12 22:52:52 UTC
*** Bug 700407 has been marked as a duplicate of this bug. ***

Comment 2 Cole Robinson 2012-01-25 02:05:40 UTC
Thinking about it some, I don't think we will ever implement this in virt-manager. For one thing, most users that want grouping features are probably managing a large number of machines and VMs which virt-manager isn't really designed for.

Your case is certainly valid but of very limited usage in my experience (most people are using the app to virtualize maybe 1 or 2 vms), so it's not that justifiable to invest development time in a possibly disruptive feature.

That said if someone popped up with a patch that implemented this in a nice unobtrusive way I'd consider it.


Note You need to log in before you can comment on or make changes to this bug.