Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 592873 - software update stuck at "checking for applications currently in use"
software update stuck at "checking for applications currently in use"
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-17 05:39 EDT by k.t.
Modified: 2011-06-27 12:25 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-27 12:25:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenie (94.37 KB, image/png)
2010-05-17 05:39 EDT, k.t.
no flags Details

  None (edit)
Description k.t. 2010-05-17 05:39:08 EDT
Created attachment 414498 [details]
screenie

Description of problem:
software update stuck at "checking for applications currently in use"

Version-Release number of selected component (if applicable):
Fedora 13 beta

How reproducible:
once maybe?

Steps to Reproduce:
1. install Fedora 13 beta
2. run update
3.
  
Actual results:
gets stuck, no reaction or change in behaviour

Expected results:
don't get stuck, do something

Additional info:
this is the second time that I am not sure against which package exactly I should submit the bug report
Comment 1 Richard Hughes 2010-05-17 07:12:38 EDT
How long did it "get stuck" for?
Comment 2 k.t. 2010-05-17 07:38:59 EDT
over two hours, could have been stayed forever if I didn't close Firefox and reopened updater
Comment 3 k.t. 2010-05-17 07:41:27 EDT
not to say that updater asked me to close Firefox, I assumed that this is why it got stuck
Comment 4 Steven M. Parrish 2010-06-04 21:50:31 EDT
This bug has been triaged



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Richard Hughes 2010-06-18 10:53:34 EDT
(In reply to comment #3)
> not to say that updater asked me to close Firefox, I assumed that this is why
> it got stuck    

No, checking the file lists shouldn't ask you to close anything. Can you reproduce this?
Comment 6 Dave Drouin 2010-08-05 10:47:07 EDT
Same thing has started happening to me recently - past week or so.  I closed Firefox but that didn't take care of this problem.  Maybe I didn't wait long enough afterwards - just about 5 minutes.   Anyway it's currently been about an hour since it started checking for applications currently in use...

Fedora Release 13
Kernel 2.6.33.5-124.fc13.i686
GNOME 2.30.0

178 updates available - all selected.

Also says this in the Software Update window:

This update will fix bugs and other non-critical problems.
This notification was issued on 07/20/2010.
Blacklisted mono-core package, because ABRT doesn't handle these crashes well.
Comment 7 Dave Drouin 2010-08-05 11:15:30 EDT
ok so deselected all of the top level packages listed except for the first oneL the ABRT.  Retried and now it works.  I also had turned on the auto update feature and requested everything be updated automatically.  So now it appears to be doing that as well.
Comment 8 Dave 2011-03-16 20:24:46 EDT
I've started seeing this symptom as well.  It's been like this for about a week, same behavior across reboot and retry (yeah, I know).

Fedora 14
Linux Linux 2.6.35.11-83.fc14.i686.PAE #1 SMP Mon Feb 7 06:57:55 UTC 2011 i686 i686 i386 GNU/Linux

I'm guessing there's an orphaned lockfile somewhere?

Disabled all but wireshark, libxml2, xulrunner, it works!
Then retried all the other patches, and they worked too.  Odd.
This bug is still out there, I hope more diagnostics will help nail it.
Comment 9 Paul Coccoli 2011-03-18 10:44:39 EDT
I've seen this twice now in the past week or so, on Fedora 13.

Right after clicking "Install Updates" in the GUI I see this in /var/log/messages:
Mar 18 10:43:26 watt abrt[10762]: saved core dump of pid 10751 (/usr/libexec/packagekitd) to /var/spool/abrt/ccpp-1300459406-10751.new/coredump (1937408 bytes)
Mar 18 10:43:26 watt abrtd: Directory 'ccpp-1300459406-10751' creation detected
Mar 18 10:43:26 watt abrtd: Crash is in database already (dup of /var/spool/abrt/ccpp-1300211864-8490)
Mar 18 10:43:26 watt abrtd: Deleting crash ccpp-1300459406-10751 (dup of ccpp-1300211864-8490), sending dbus signal
Comment 10 Bug Zapper 2011-06-02 09:55:59 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Bug Zapper 2011-06-27 12:25:30 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.