Bug 59288 - kghostview crashes on exit
kghostview crashes on exit
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: kdegraphics (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-04 13:45 EST by Tim Waugh
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-04 13:45:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2002-02-04 13:45:38 EST
Description of Problem:
Kghostview always crashes when you close it.

Version-Release number of selected component (if applicable):
kdegraphics-kghostview-3.0.0-0.cvs20020129.1

How Reproducible:
100%

Steps to Reproduce:
1. Start kghostview
2. Close the window.

Actual Results:
(no debugging symbols found)...[New Thread 1024 (LWP 11119)]
0x410d7ff9 in wait4 () from /lib/i686/libc.so.6
#0  0x410d7ff9 in wait4 () from /lib/i686/libc.so.6
#1  0x41166690 in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x40f02483 in waitpid () from /lib/i686/libpthread.so.0
#3  0x406bdaa9 in KCrash::defaultCrashHandler(int) ()
   from /usr/lib/libkdecore.so.4
#4  0x40f007fc in pthread_sighandler () from /lib/i686/libpthread.so.0
#5  <signal handler called>
#6  0x080bb9d6 in ?? ()
#7  0x40058306 in KPSWidget::disableInterpreter() ()
   from /usr/lib/libkghostview.so
#8  0x400495dc in KGVMiniWidget::reset() () from /usr/lib/libkghostview.so
#9  0x40047385 in KGVMiniWidget::~KGVMiniWidget() ()
   from /usr/lib/libkghostview.so
#10 0x4099ed2b in QObject::~QObject() () from /usr/lib/qt3/lib/libqt-mt.so.3
#11 0x4012f911 in KParts::Part::~Part() () from /usr/lib/libkparts.so.2
#12 0x401300e7 in KParts::ReadOnlyPart::~ReadOnlyPart() ()
   from /usr/lib/libkparts.so.2
#13 0x4005ff95 in KGVPart::~KGVPart() () from /usr/lib/libkghostview.so
#14 0x409ce548 in QWidget::~QWidget() () from /usr/lib/qt3/lib/libqt-mt.so.3
#15 0x40a70c2c in QMainWindow::~QMainWindow() ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#16 0x404bc0c5 in KMainWindow::~KMainWindow() () from /usr/lib/libkdeui.so.4
#17 0x40136dc8 in KParts::MainWindow::~MainWindow() ()
   from /usr/lib/libkparts.so.2
#18 0x400562c0 in KGVShell::~KGVShell() () from /usr/lib/libkghostview.so
#19 0x4099f732 in QObject::event(QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0x409d3adc in QWidget::event(QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#21 0x40a72e72 in QMainWindow::event(QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0x40952ce4 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#23 0x409525c3 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#24 0x4064ebc6 in KApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libkdecore.so.4
#25 0x409536bb in QApplication::sendPostedEvents(QObject*, int) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0x40953598 in QApplication::sendPostedEvents() ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0x408f9bed in QApplication::processNextEvent(bool) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#28 0x409542c0 in QApplication::enter_loop() ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0x408f95bd in QApplication::exec() () from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0x080491be in KApplication::~KApplication() ()
#31 0x41037108 in __libc_start_main () from /lib/i686/libc.so.6
Comment 1 Tim Waugh 2002-03-15 13:53:02 EST
This seems to be fixed in kghostview-3.0.0-0.cvs20020307.1.

Note You need to log in before you can comment on or make changes to this bug.