Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 592985 - passing proxy=http://url anaconda boot option does not load kickstart file
passing proxy=http://url anaconda boot option does not load kickstart file
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-17 10:36 EDT by Marcus Moeller
Modified: 2010-05-18 10:48 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-17 12:10:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcus Moeller 2010-05-17 10:36:35 EDT
Description of problem:

While trying to install F13 RC3 through a http proxy, kickstart file is not retrieved.

Version-Release number of selected component (if applicable):

Steps to Reproduce:
1. Boot install media, hit tab at grub menu
2. Add proxy=http://proxy.home:3128 to the kernel line
3. Hit enter and attempt to install

Actual results:
kickstart file is not retrieved

Expected results:
kickstart file should be retrieved and next stage of Anaconda should be loaded
Comment 1 Brian Lane 2010-05-17 11:16:27 EDT
If you have them, could you attach the /tmp/*log files to this? I'll try to reproduce it as well.
Comment 2 Brian Lane 2010-05-17 12:10:27 EDT
I tried this with F13 RC3 netboot iso. Passed it proxy=http://proxy.home:3128 ks=http://proxy.home/ks/f13-minimal.ks

It retrieves the ks file and stores it into /tmp/ks.cfg
Comment 3 Marcus Moeller 2010-05-18 05:02:59 EDT
In our case, we are retrieving the kickstart file from a Spacewalk server, so maybe this is an incompatibility caused by the latest Anaconda patch additions. Just thought it was a F13 client problem because F12 worked fine, even with proxy set.

Going to check on Spacewalk side, now.

Btw. thanks for trying to reproduce this issue.

Best Regards
Marcus
Comment 4 Brian Lane 2010-05-18 10:38:40 EDT
A couple of things to look for:

 * Check /tmp/anaconda.log which near the top should show that it downloaded your kickstart file
 * Look at /tmp/ks.cfg which should be your kickstart file

You can do this by switching to tty2 after the GUI part of the installer has started.
Comment 5 Marcus Moeller 2010-05-18 10:48:02 EDT
Thanks for the advice, but the installation does not went that far.

Best Regards
Marcus

Note You need to log in before you can comment on or make changes to this bug.