Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 593019 - ConfigParser.NoSectionError: No section: 'main'
Summary: ConfigParser.NoSectionError: No section: 'main'
Keywords:
Status: CLOSED DUPLICATE of bug 592485
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.0
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-17 15:54 UTC by Marian Csontos
Modified: 2010-05-18 14:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-18 14:06:24 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Marian Csontos 2010-05-17 15:54:41 UTC
Description of problem:
I tried to install
- Distro: RHEL6.0-20100517.n.0_nfs-Server-x86_64
- Via: beaker
- On Machine: tyan-gt24-01.rhts.eng.bos.redhat.com

which resulted in:

    Welcome to Red Hat Enterprise Linux for x86_64

    Traceback (most recent call last):
    File "/usr/bin/anaconda", line 1021, in <module>
            from exception import initExceptionHandling
    File "/usr/lib/anaconda/exception.py", line 24, in <module>
            from meh.handler import *
    File "/usr/lib/python2.6/site-packages/meh/handler.py", line 25, in <module>
            import report.accountmanager
    File "/usr/lib64/python2.6/site-packages/report/__init__.py", line 36, in <module>
            from report import io as iomodule
    File "/usr/lib64/python2.6/site-packages/report/io/__init__.py", line 13, in <module>
            priority = prio_mappings[config.get("main","loglevel")]
    File "/usr/lib64/python2.6/ConfigParser.py", line 311, in get
            raise NoSectionError(section)
    ConfigParser.NoSectionError: No section: 'main'
    install exited abnormally [1/1] 
    The system will be rebooted when you press Ctrl-C or Ctrl-Alt-Delete.

NOTE: it spent long minutes hanging on this message:

    Greetings.
    anaconda installer init version 13.21.41 starting
    mounting /proc filesystem... done
    creating /dev filesystem... done
    starting udev...done
    mounting /dev/pts (unix98 pty) filesystem... done
    mounting /sys filesystem... done
    anaconda installer init version 13.21.41 using a serial console
    trying to remount root filesystem read write... done
    mounting /tmp as tmpfs... done
    running install...
    running /sbin/loader
    Gdetecting hardware...
    waiting for hardware to initialize...

Version-Release number of selected component (if applicable):
RHEL6.0-20100517.n.0_nfs-Server-x86_64

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Installation failed.

Expected results:
System installed.

Additional info:

Comment 2 Bill Nottingham 2010-05-18 14:06:24 UTC

*** This bug has been marked as a duplicate of bug 592485 ***


Note You need to log in before you can comment on or make changes to this bug.