Bug 593117 - gcc44 -O issue Xor instructions optimized out.
gcc44 -O issue Xor instructions optimized out.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gcc44 (Show other bugs)
5.5
All Linux
high Severity high
: rc
: ---
Assigned To: Jakub Jelinek
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-17 16:54 EDT by Alan Matsuoka
Modified: 2011-05-13 08:57 EDT (History)
2 users (show)

See Also:
Fixed In Version: gcc44-4.4.4-13.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 19:01:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
markh_bug.c (858 bytes, text/plain)
2010-05-17 16:56 EDT, Alan Matsuoka
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0102 normal SHIPPED_LIVE gcc44 bug fix update 2011-01-12 12:21:10 EST

  None (edit)
Description Alan Matsuoka 2010-05-17 16:54:45 EDT
All Issues: Problem Description
---------------------------------------------------
1. Time and date of problem:
N/A
2. System architecture(s):
RHEL 5.4, x86_64 gcc44
3. Provide a clear and concise problem description as it is understood at the
  time of escalation. Please be as specific as possible in your description.
  Do not use the generic term "hang", as that can mean many things.
  Observed behavior:
Using the attached reproducer (markh_bug.c) we see the following:

$ gcc44 -O -o rehl5.5_gcc_O1 markh_bug.c
$ ./rehl5.5_gcc_O1
ff7f0000 ff7f0000 ff7f0000 - FAIL

  Desired behavior:

That this test case work with gcc44 and level 1 optimization:

$ gcc44 -O2 -o rehl5.5_gcc_O2 markh_bug.c
$ ./rehl5.5_gcc_O2
05020300 09060704 0d0a0b08 - OK

4. Specific action requested of SEG:

Please help me to identify the fix that went into later versions of gcc (gcc 4.4.3 from Fedora 12) to back port to RHEL 5.

5. Is a defect (bug) in the product suspected? yes

6. Does a proposed patch exist? yes and no

Since this seems to be fixed in Fedora 12 (gcc 4.4.3) I'm sure a patch exists somewhere, but I don't know which one.

7. What is the impact to the customer when they experience this problem?
  Customer is continuing their work on porting their applications to gcc 44 to be ready for RHEL 6.

Further Information:
As mentioned above I have verified that this issue does not happen on Fedora 12 with both gcc 4.4.2 and 4.4.3. The fix is out there, but I'm afraid I don't know which one it is.

-Heath

SEG Notes:

The Xor instructions are being optimized out at -O1.
I thought that it was BZ 40087 but that doesn't seem to be the case.
Comment 1 Alan Matsuoka 2010-05-17 16:56:23 EDT
Created attachment 414667 [details]
markh_bug.c
Comment 2 Jakub Jelinek 2010-05-17 17:11:20 EDT
Why do you need to know which patch was it?  If gcc44 is ever errataed again in RHEL 5, it would be updated to current RHEL6 gcc.  Nothing else makes any sense.
Comment 3 Alan Matsuoka 2010-05-17 17:13:29 EDT
I don't. I forgot to remove that comment.
Comment 8 errata-xmlrpc 2011-01-13 19:01:04 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0102.html

Note You need to log in before you can comment on or make changes to this bug.