This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 59316 - New glibc 2.1.3-23 breaks Kylix install
New glibc 2.1.3-23 breaks Kylix install
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
6.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-04 23:12 EST by Richard Westcott
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-04 23:12:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard Westcott 2002-02-04 23:12:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20020104

Description of problem:
I upgraded to the new glibc 2.1.3-23 via RedHat Network. This over wrote the
glibc 2.1.3-22B I had installed from my Kylix 1 install CDs. When I attempt to
launch Kylix after the upgrade, Kylix will not fully launch. According to
Borland, this is a known bug that was in glibc 2.1.3-22 that they had corrected
by including the glibc 2.1.3-22B RPMs on the Kylix install CD. I mistakenly
assumed that the new glibc 2.1.3-23 had the same fixes. I just recieved my
updated Kylix 2 CDs and they will not install because of the known "loader" bug.

Version-Release number of selected component (if applicable): glibc 2.1.3-23


How reproducible:
Always

Steps to Reproduce:
1. Attempt to launch an existing Kylix 1 isntall - or -
2. Attempt to install/upgrade to Kylix 2
	

Actual Results:  If I attempt to launch kylix 1, it gets as far as showing the
splash screen and stops. A look at TOP shows the program IS running, but not
fully launched.

If I attempt to install Kylix 2, the install fails after checking for glibc
compatibility.

Expected Results:  Kylix 1 should launch to a full IDE GUI.

Kylix 2 should install.

Additional info:

According to Borland, this is a known bug in glibc 2.1.3-22. They fixed it and
included RPMs for glibc 2.1.3-22B. I thought that those fixes would be in
2.1.3-23. I have discovered they are not.

What I need is either a fix for glibc 2.1.3-23 or a way to down grade to the
glibc 2.1.3-22B RPMs on the Kylix install CDs.
Comment 1 Jakub Jelinek 2002-02-05 05:46:10 EST
Borland would have to propagate their changes back to us, which never happened.
So, you basically need to take their glibc-2.1.3-22B src.rpm, grab the patch(es)
they have added, rpm -i glibc-2.1.3-23.src.rpm, edit /usr/src/redhat/SPECS/glibc.spec
so that it applies Borland patches and rpm -ba glibc.spec (change the release
from 23 to 23B). Alternatively, take the patch from glibc-2.1.3-23 and apply
it to glibc-2.1.3-22B.

Note You need to log in before you can comment on or make changes to this bug.