Bug 593193 - [vdsm] [libvirt intg] nfs over root_squash (cannot start domain over nfs)
Summary: [vdsm] [libvirt intg] nfs over root_squash (cannot start domain over nfs)
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Daniel Berrange
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords: Regression, TestBlocker
Depends On:
Blocks: 581275
TreeView+ depends on / blocked
 
Reported: 2010-05-18 06:23 UTC by Haim
Modified: 2014-01-13 00:46 UTC (History)
12 users (show)

Fixed In Version: libvirt-0.8.1-6.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 19:33:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Haim 2010-05-18 06:23:15 UTC
Description of problem:

we seem to have a regression on latest libvirt build: libvirt-0.8.1-4.el6.x86_64, as I cannot start domain over nfs storage using libvirt. 

Get the following error: 

(03:32:26 PM) danken: 14:43:01.119: error : qemuSetupDiskCgroup:3390 : Unable to allow device /rhev/data-center/fb89b279-1019-456b-be42-fb4d35587970/cfc7045f-89b5-4f67-96e6-15e3bc3b0f31/images/2a2a0442-a041-499d-8915-ab23318138a0/dc86136a-3718-4f3a-ba44-17effc0af5b9 for libvirt-nfs2-desk-06: Permission denied

also have to keep security_driver=none, or else I get
(03:35:32 PM) danken: 15:34:38.005: error : SELinuxSetFilecon:339 : unable to set security context 'system_u:object_r:svirt_image_t:s0:c257,c620' on '/rhev/data-center/fb89b279-1019-456b-be42-fb4d35587970/cfc7045f-89b5-4f67-96e6-15e3bc3b0f31/images/2a2a0442-a041-499d-8915-ab23318138a0/dc86136a-3718-4f3a-ba44-17effc0af5b9': Permission denied
15:34:38.012: error : qemuSetupDiskCgroup:3390 : Unable to allow device /rhev/data-center/fb89b279-1019-456b-be42-fb4d35587970/cfc7045f-89b5-4f67-96e6-15e3bc3b0f31/images/2a2a0442-a041-499d-8915-ab23318138a0/dc86136a-3718-4f3a-ba44-17effc0af5b9 for libvirt-nfs2-desk-06: Permission denied
(03:35:32 PM) danken: 15:34:38.063: error : SELinuxRestoreSecurityFileLabel:369 : cannot stat (null): Bad address

Version-Release number of selected component (if applicable):

vdsm-4.9-6.el6.x86_64
libvirt-0.8.1-4.el6.x86_64
qemu-kvm-0.12.1.2-2.53.el6.x86_64


How reproducible: always 


Steps to Reproduce: 100%
1. create a new domain using nfs storage 
2. start new domain in virsh

Comment 3 Laine Stump 2010-05-18 14:21:22 UTC
I believe Dan Berrange knows the cause of this and has a fix.

Comment 5 Dave Allan 2010-05-19 16:36:22 UTC
libvirt-0.8.1-6.el6 has been built in RHEL-6-candidate with the fix

Dave

Comment 7 Haim 2010-06-08 07:44:59 UTC
verified on libvirt-0.8.1-7.el6.x86_64. 

manage to start domain over nfs storage domain


package versions: 

vdsm-4.9-8.el6.x86_64
libvirt-0.8.1-7.el6.x86_64
qemu-kvm-0.12.1.2-2.69.el6.x86_64
2.6.32-33.el6.x86_64

Comment 8 releng-rhel@redhat.com 2010-07-02 19:33:42 UTC
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.