Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 593210 - RFE: Add /etc/sysctl.d/ support
RFE: Add /etc/sysctl.d/ support
Status: CLOSED DUPLICATE of bug 574870
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: procps (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Jan Görig
BaseOS QE - Apps
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-18 03:55 EDT by Jens Kuehnel
Modified: 2010-05-18 11:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-18 11:00:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Kuehnel 2010-05-18 03:55:52 EDT
Description of problem:

We have a *.d for almost everything, but not for sysctl.

We manage our servers with satellite, and some of our rpms would like to change things in /etc/sysctl.conf. It has to be done in the rpm, because some of our customers are not using RHN.

Of course the fix would be trivial.

Add to rc.sysint after:
sysctl -e -p /etc/sysctl.conf

for i in /etc/sysctl.d/*
do
  test -f $i && sysctl -e -p $i
done

The same thing exist in Debian/Ubuntu.
Comment 2 Bill Nottingham 2010-05-18 11:00:51 EDT

*** This bug has been marked as a duplicate of bug 574870 ***

Note You need to log in before you can comment on or make changes to this bug.