Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 593333 - virt-manager: Fix automatic keymap resolution
virt-manager: Fix automatic keymap resolution
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-18 10:39 EDT by Cole Robinson
Modified: 2010-11-10 16:53 EST (History)
7 users (show)

See Also:
Fixed In Version: virt-manager-0.8.4-7.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:53:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Straight backport from upstream (2.07 KB, text/plain)
2010-05-18 11:00 EDT, Cole Robinson
no flags Details
Proper fix for VNC keymap issue (3.66 KB, text/plain)
2010-07-07 11:19 EDT, Cole Robinson
no flags Details

  None (edit)
Description Cole Robinson 2010-05-18 10:39:07 EDT
QEMU and gtk-vnc in RHEL6 cooperate to transparently use the host keymap in the guest. However, virt-manager is incorrectly trying to guess the desired keymap, which overrides the qemu/gtk-vnc behavior.

This is fixed by the upstream commit:

http://hg.fedorahosted.org/hg/virt-manager/rev/7b09131ffffc

Before and after the patch, do the following:

- Create a guest with virt-manager.
- virsh dumpxml $vmname | grep keymap

Before the patch, there will be a keymap= returned
After the patch, no keymap will be specified.

FYI, if there is no keymap= value in the XML and the guest has messed up keymap, it isn't a virt-manager issue.
Comment 1 RHEL Product and Program Management 2010-05-18 10:55:23 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Cole Robinson 2010-05-18 11:00:48 EDT
Created attachment 414882 [details]
Straight backport from upstream
Comment 3 Cole Robinson 2010-05-18 11:37:40 EDT
Fix built in virt-manager-0.8.4-3.el6
Comment 5 dyuan 2010-07-06 01:10:12 EDT
Test with virt-manager-0.8.4-6.el6, Create a guest with virt-manager, then virsh dumpxml $vmname | grep keymap, there is only a '<graphics type='vnc' port='5900' autoport='yes' keymap='en-us'/>' returned, and get the same testing result with **virt-manager-0.8.4-2.el6**.

Is that the expected result ?
Comment 6 Cole Robinson 2010-07-07 11:19:51 EDT
Created attachment 430092 [details]
Proper fix for VNC keymap issue

Good catch, the original patch only pulled one half of the default device model fixes. This patch now contains the important part.
Comment 7 Cole Robinson 2010-07-07 11:26:20 EDT
Proposing as a blocker: the additional change to fix this bug is small and low risk. Not fixing this in 5.0 will definitely yeild bug reports from users, since current behavior falls back to en-us keymap setting for most new virtual machines.
Comment 10 Cole Robinson 2010-07-13 16:25:40 EDT
Fix built in virt-manager-0.8.4-7.el6
Comment 12 yanbing du 2010-07-22 05:29:08 EDT
Verified with virt-manager-0.8.4-7.el6.
Create a guest with virt-manage, then virsh dumpxml $vmname | grep keymap, nothing returned.
Comment 13 min zhan 2010-09-13 02:06:46 EDT
Verified Passed with virt-manager-0.8.4-8.el6.noarch.
Comment 14 releng-rhel@redhat.com 2010-11-10 16:53:49 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.