Bug 593342 - Poor RHEL6 kdm theme dual-head behavior
Summary: Poor RHEL6 kdm theme dual-head behavior
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kdebase-workspace
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Jaroslav Reznik
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-18 14:52 UTC by Ian Pilcher
Modified: 2010-11-19 07:57 UTC (History)
5 users (show)

Fixed In Version: kdebase-workspace-4.3.4-19.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-15 14:00:22 UTC
Target Upstream Version:


Attachments (Terms of Use)
RHEL6 kdm theme on RHEL 6 beta (382.67 KB, image/jpeg)
2010-05-18 14:52 UTC, Ian Pilcher
no flags Details
dmesg from Fedora 13 (53.35 KB, text/plain)
2010-06-21 20:58 UTC, Ian Pilcher
no flags Details
X.org log from Fedora 13 (89.52 KB, text/plain)
2010-06-21 20:59 UTC, Ian Pilcher
no flags Details
dmesg from RHEL 6 beta (52.95 KB, text/plain)
2010-06-21 21:07 UTC, Ian Pilcher
no flags Details
X.org log from RHEL 6 beta (49.14 KB, application/octet-stream)
2010-06-21 21:07 UTC, Ian Pilcher
no flags Details
RHEL6 kdm theme on Fedora 13 (756.86 KB, image/jpeg)
2010-06-21 21:09 UTC, Ian Pilcher
no flags Details
Proposed patch (480 bytes, patch)
2010-06-23 12:58 UTC, Jaroslav Reznik
no flags Details | Diff

Description Ian Pilcher 2010-05-18 14:52:20 UTC
Created attachment 414880 [details]
RHEL6 kdm theme on RHEL 6 beta

Description of problem:
My laptop has a built in 1680x1050 LCD.  At times it is also connected
to an external 1280x1024 LCD.  When it is connected to the external
LCD, the RHEL6 kdm theme is not attractive.

Nothing is displayed on the external display.  The theme is displayed on
the built-in LCD, but the area used appears to be limited to the resolution
of the external display.  (Picture attached.)

Version-Release number of selected component (if applicable):
redhat-logos-60.0.10-1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1.  Install RHEL 6 beta on appropriate hardware.
2.  Attach external display.
3.  Set DISPLAYMANAGER=KDE in /etc/sysconfig/desktop
4.  Reboot
  
Actual results:
See attached picture.

Expected results:
Background should be displayed on external display.  Theme should use
full resolution of built-in display.

Additional info:

Comment 2 RHEL Program Management 2010-06-07 16:00:32 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Lukáš Tinkl 2010-06-10 12:55:39 UTC
CC'ing jreznik as he's the author of the kdm theme; Jaroslav, is this possible in kdm?

Comment 5 Jaroslav Reznik 2010-06-21 12:36:31 UTC
This is not a KDM issue - it supports background on second (external) monitor (and it works for me correctly on NVidia card with Nouveau drivers). The problem is in graphics subsystem - dual head misconfiguration or graphics driver dual head support problem.

What's your graphics card? Which drivers do you use? Could you attach your XOrg logs/dmesg log?

Comment 6 Ian Pilcher 2010-06-21 20:58:45 UTC
Created attachment 425747 [details]
dmesg from Fedora 13

Comment 7 Ian Pilcher 2010-06-21 20:59:39 UTC
Created attachment 425748 [details]
X.org log from Fedora 13

Comment 8 Ian Pilcher 2010-06-21 21:07:23 UTC
Created attachment 425750 [details]
dmesg from RHEL 6 beta

Comment 9 Ian Pilcher 2010-06-21 21:07:57 UTC
Created attachment 425751 [details]
X.org log from RHEL 6 beta

Comment 10 Ian Pilcher 2010-06-21 21:09:45 UTC
Created attachment 425753 [details]
RHEL6 kdm theme on Fedora 13

Comment 11 Ian Pilcher 2010-06-21 21:12:30 UTC
Hardware is a Lenovo ThinkPad T61 with Intel graphics.  I have both RHEL 6 beta and Fedora 13 installed on this system, and I have "branded" the Fedora 13 install with the redhat-logos package from RHEL 6 beta.  This allows me to run KDM with the RHEL 6 theme under both RHEL 6 beta and Fedora 13 on this hardware.

As you can see from the uploaded picture, the theme works just fine on Fedora 13.  I have attached dmesg output and X.org logs from both Fedora 13 (works) and RHEL 6 beta (doesn't work).

Comment 12 Jaroslav Reznik 2010-06-23 12:58:25 UTC
Created attachment 426257 [details]
Proposed patch

Ok, thanks.

I've found the problem - seems like Qt 4.6 sometimes does not repaint background properly. Events triggers repaint.

Comment 17 Jaroslav Reznik 2010-06-25 08:38:23 UTC
Fixed in kdebase-workspace-4.3.4-19.el6.

Comment 19 Vladimir Benes 2010-11-12 15:53:43 UTC
Hi Ian,
could you please verify on your HW set that this issue is fixed? 

Thank you,
Vladimir

Comment 20 releng-rhel@redhat.com 2010-11-15 14:00:22 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Comment 21 Ian Pilcher 2010-11-19 00:22:39 UTC
(In reply to comment #19)
> Hi Ian,
> could you please verify on your HW set that this issue is fixed? 

I no longer have a T61 to test.  It seems to work OK on a T60.

Comment 22 Tomas Pelka 2010-11-19 07:57:57 UTC
Thank you Ian.


Note You need to log in before you can comment on or make changes to this bug.