Bug 593562 - anaconda: DeviceError: ('cannot replace active format', 'sda1')
anaconda: DeviceError: ('cannot replace active format', 'sda1')
Status: CLOSED DUPLICATE of bug 570474
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
anaconda_trace_hash:6fb78d4ae1ea18192...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-19 03:02 EDT by Jan Engelhardt
Modified: 2010-05-19 15:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-19 15:48:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (267.33 KB, text/plain)
2010-05-19 03:02 EDT, Jan Engelhardt
no flags Details

  None (edit)
Description Jan Engelhardt 2010-05-19 03:02:03 EDT
The following was filed automatically by anaconda:
anaconda 13.21.20.5 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 697, in _setFormat
    raise DeviceError("cannot replace active format", self.name)
  File "/usr/lib/anaconda/storage/devices.py", line 1171, in _setFormat
    StorageDevice._setFormat(self, format)
  File "/usr/lib/anaconda/storage/devices.py", line 705, in <lambda>
    lambda d,f: d._setFormat(f),
  File "/usr/lib/anaconda/storage/deviceaction.py", line 307, in __init__
    self.device.format = None
  File "/usr/lib/anaconda/storage/__init__.py", line 782, in destroyDevice
    self.devicetree.registerAction(ActionDestroyFormat(device))
  File "/usr/lib/anaconda/storage/partitioning.py", line 370, in clearPartitions
    storage.destroyDevice(part)
  File "/usr/lib/anaconda/storage/partitioning.py", line 184, in doAutoPartition
    clearPartitions(anaconda.id.storage)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 655, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 1048, in <module>
    anaconda.intf.run(anaconda)
DeviceError: ('cannot replace active format', 'sda1')
Comment 1 Jan Engelhardt 2010-05-19 03:02:07 EDT
Created attachment 415038 [details]
Attached traceback automatically from anaconda.
Comment 3 David Lehman 2010-05-19 15:48:29 EDT

*** This bug has been marked as a duplicate of bug 570474 ***
Comment 4 Jan Engelhardt 2010-05-19 15:51:38 EDT
Except the partition table had no EFI in it at all in my case.

Note You need to log in before you can comment on or make changes to this bug.