Bug 593637 - anaconda doesn't understand LVM setup with a PV on device without partition table
anaconda doesn't understand LVM setup with a PV on device without partition t...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: David Lehman
Release Test Team
:
Depends On: 600225
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-19 07:31 EDT by Dan Horák
Modified: 2010-11-10 14:43 EST (History)
3 users (show)

See Also:
Fixed In Version: anaconda-13.21.50-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 14:43:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (7.35 KB, text/plain)
2010-05-19 07:32 EDT, Dan Horák
no flags Details
program.log (26.33 KB, text/plain)
2010-05-19 07:32 EDT, Dan Horák
no flags Details
storage.log (79.94 KB, text/plain)
2010-05-19 07:32 EDT, Dan Horák
no flags Details
syslog (56.11 KB, text/plain)
2010-05-19 07:33 EDT, Dan Horák
no flags Details
logs and screenshots (351.26 KB, application/x-bzip)
2010-05-26 07:10 EDT, Dan Horák
no flags Details
logs (27.31 KB, application/x-bzip)
2010-06-07 06:21 EDT, Dan Horák
no flags Details

  None (edit)
Description Dan Horák 2010-05-19 07:31:35 EDT
Description of problem:
I tried to install RHEL6 pre Beta2 Snap4 into a LV on my workstation with an existing LVM setup. And it seems that anaconda doesn't understand LVM setup with a PV placed directly on a device without partition table (sdc). It does detect the disks (sda, sdb, sdc = logical disks on Areca HW RAID array), but on the Custom storage setup page it offers sda (with a an ext3 partition) and sdc (as an empty disk). sdb wasn't selected as available in the Basic storage devices setup, because it contains other OS installation.

Version-Release number of selected component (if applicable):
RHEL 6 pre Beta2 Snapshot 4 Workstation x86_64
Comment 1 Dan Horák 2010-05-19 07:32:09 EDT
Created attachment 415086 [details]
anaconda.log
Comment 2 Dan Horák 2010-05-19 07:32:29 EDT
Created attachment 415088 [details]
program.log
Comment 3 Dan Horák 2010-05-19 07:32:49 EDT
Created attachment 415089 [details]
storage.log
Comment 4 Dan Horák 2010-05-19 07:33:04 EDT
Created attachment 415090 [details]
syslog
Comment 6 RHEL Product and Program Management 2010-05-19 07:55:09 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 7 David Lehman 2010-05-24 14:52:59 EDT
This looks like it might be the same as bug 588637. Please test with the tree noted in that bug (https://bugzilla.redhat.com/show_bug.cgi?id=588637#c5) and see if your problem has been resolved.
Comment 8 Dan Horák 2010-05-25 05:24:15 EDT
The 20100520.0 tree doesn't even start the GUI part of installation here, I will try a newer one.
Comment 9 Dan Horák 2010-05-26 07:10:07 EDT
Created attachment 416768 [details]
logs and screenshots

RHEL6.0-20100523.0 with anaconda-13.21.45-1.el6.x86_64.rpm starts the GUI part of the installer, but no change in behaviour
Comment 10 David Lehman 2010-05-26 12:25:18 EDT
The problem is that parted thinks there is a DOS partition table on your disk (and we believe it). I just noticed that they've added partition table detection to blkid, so I'll work on a patch to improve anaconda's ability to identify partitioned devices.
Comment 12 Dan Horák 2010-06-07 06:21:30 EDT
Created attachment 421777 [details]
logs

Unfortunately no change with rel-eng/RHEL6.0-20100603.1 tree, the whole /dev/sdc is marked as free
Comment 13 David Lehman 2010-06-07 10:47:32 EDT
Something has changed outside of anaconda. In your last logs (from comment 9) it was shown that udev identified sdc as an LVM PV, while in your last run this is no longer the case. The evidence is the ID_FS_TYPE item in udev info dict, found in storage.log on a line starting with (after timestamp):

  DeviceTree.addUdevDevice: info:

You will notice that in the older logs there is an item in the dict:

  'ID_FS_TYPE': 'LVM2_member'

as well as several lvm-specific items. The new logs show no indication that udev found any formatting at all on sdc.

Can you get to a shell during the install and run a command? If so, run this:

  blkid -o udev -p /dev/sdc

and post the output (if there is any) in this bug report.
Comment 14 David Lehman 2010-06-07 11:36:27 EDT
The lack of udev information is due to bug 600225. Once that bug has been resolved, you can retest this one.
Comment 15 Dan Horák 2010-06-07 12:03:02 EDT
(In reply to comment #13)
> Something has changed outside of anaconda. In your last logs (from comment 9)
> it was shown that udev identified sdc as an LVM PV, while in your last run this
> is no longer the case. The evidence is the ID_FS_TYPE item in udev info dict,
> found in storage.log on a line starting with (after timestamp):
> 
>   DeviceTree.addUdevDevice: info:
> 
> You will notice that in the older logs there is an item in the dict:
> 
>   'ID_FS_TYPE': 'LVM2_member'
> 
> as well as several lvm-specific items. The new logs show no indication that
> udev found any formatting at all on sdc.
> 
> Can you get to a shell during the install and run a command? If so, run this:
> 
>   blkid -o udev -p /dev/sdc
> 
> and post the output (if there is any) in this bug report.    

ID_FS_UUID=AzeQ0w-umUu-5aK4-13Wu-VmFF-9k8x-920OUW
ID_FS_UUID_ENC=AzeQ0w-umUu-5aK4-13Wu-VmFF-9k8x-920OUW
ID_FS_VERSION=LVM2\x20001
ID_FS_TYPE=LVM2_member
ID_FS_USAGE=raid
Comment 17 Dan Horák 2010-07-01 04:08:46 EDT
Successfully tested with the 20100622.1 tree, the existing LVM setup was available to anaconda for installation.
Comment 19 releng-rhel@redhat.com 2010-11-10 14:43:49 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.