Bug 593698 - [abrt] crash in thunderbird-3.0.4-2.el6: raise signal 11 (SIGSEGV) [@ nsMsgDBView::RemoveRows]
Summary: [abrt] crash in thunderbird-3.0.4-2.el6: raise signal 11 (SIGSEGV) [@ nsMsgDB...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: thunderbird   
(Show other bugs)
Version: 6.0
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Jan Horak
QA Contact: Desktop QE
URL:
Whiteboard: abrt_hash:1e81deafc41b3feeb56d736c09a...
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-19 14:22 UTC by Matěj Cepl
Modified: 2012-03-26 11:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-26 11:37:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (92.92 KB, text/plain)
2010-05-19 14:22 UTC, Matěj Cepl
no flags Details

Description Matěj Cepl 2010-05-19 14:22:25 UTC
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/thunderbird-3.0/thunderbird-bin
component: thunderbird
crash_function: raise
executable: /usr/lib64/thunderbird-3.0/thunderbird-bin
global_uuid: 1e81deafc41b3feeb56d736c09a856cc8e63e4f9
kernel: 2.6.32-25.el6.x86_64
package: thunderbird-3.0.4-2.el6
rating: 4
reason: Process /usr/lib64/thunderbird-3.0/thunderbird-bin was killed by signal 11 (SIGSEGV)
release: Red Hat Enterprise Linux release 6.0 Beta (Santiago)

How to reproduce
-----
1.entering one particular folder on RH IMAP (mozilla-list) causes TB to go down
2.
3.

Comment 1 Matěj Cepl 2010-05-19 14:22:32 UTC
Created attachment 415136 [details]
File: backtrace

Comment 2 Matěj Cepl 2010-05-19 14:23:40 UTC
#2  <signal handler called>
No symbol table info available.
#3  0x0000003d97284220 in _wordcopy_fwd_aligned () from /lib64/libc.so.6
No symbol table info available.
#4  0x0000003d972828f2 in memmove () from /lib64/libc.so.6
No symbol table info available.
#5  0x00007ffd1883eabc in nsMsgDBView::RemoveRows (this=0x7ffd0d285c00, 
    viewIndex=1063, numRows=4)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mailnews/base/src/nsMsgDBView.cpp:5209
No locals.
#6  0x00007ffd1883d89d in nsMsgDBView::CollapseByIndex (
    this=<value optimized out>, index=<value optimized out>, pNumCollapsed=
    0x7fffb15c178c)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mailnews/base/src/nsMsgDBView.cpp:4784
        rv = 0
        flags = <value optimized out>
        rowDelta = -4
        numRemoved = 4
#7  0x00007ffd1884baa9 in nsMsgThreadedDBView::MoveThreadAt (this=
    0x7ffd0d285c00, threadIndex=1062)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mailnews/base/src/nsMsgThreadedDBView.cpp:810
        collapseCount = 32765
        preservedSelection = {<nsTArray<unsigned int>> = {<nsTArray_base> = {
              static sEmptyHdr = {mLength = 0, mCapacity = 0, mIsAutoArray = 
    0}, mHdr = 0x7fffb15c17a8}, <No data fields>}, mAutoBuf = 
    "\000\000\000\000\001\000\000\200\000d\251\375"}
        threadFlags = {<nsTArray_base> = {static sEmptyHdr = {mLength = 0, 
              mCapacity = 0, mIsAutoArray = 0}, mHdr = 
    0x7ffcfb8f7920}, <No data fields>}
        currentIndex = 0
        saveFlags = 1207959696
        threadIsExpanded = 1
        threadLevels = {<nsTArray_base> = {static sEmptyHdr = {mLength = 0, 
              mCapacity = 0, mIsAutoArray = 0}, mHdr = 
    0x7ffcf6114210}, <No data fields>}
        changesDisabled = 0
        hasSelection = 1
        threadKeys = {<nsTArray_base> = {static sEmptyHdr = {mLength = 0, 
              mCapacity = 0, mIsAutoArray = 0}, mHdr = 
    0x7ffcfb8f7900}, <No data fields>}
        newIndex = <value optimized out>
        lowIndex = 52428784
        threadHdr = {<nsCOMPtr_base> = {mRawPtr = 
    0x7ffcf43cf6a0}, <No data fields>}
        childCount = 4
        preservedKey = <value optimized out>
        selectionCount = 32765
        highIndex = <value optimized out>
#8  0x00007ffd1884bd40 in nsMsgThreadedDBView::OnNewHeader (this=
    0x7ffd0d285c00, newHdr=0x7ffcf4539220, aParentKey=<value optimized out>, 
    ensureListed=<value optimized out>)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mailnews/base/src/nsMsgThreadedDBView.cpp:690
        flags = <value optimized out>
        threadCount = 3
        threadFlags = 0
        threadRootIsDisplayed = 0
        moveThread = 1
        threadIndex = 1062
        threadHdr = {<nsCOMPtr_base> = {mRawPtr = 
    0x7ffcfbc53ab0}, <No data fields>}
        rv = 0
        newKey = 225870
#9  0x00007ffd1884f1f4 in nsMsgQuickSearchDBView::OnNewHeader (this=

Comment 4 Matěj Cepl 2010-05-19 14:29:07 UTC
Seem like having a duplicate in Fedora bug 546865

Comment 5 RHEL Product and Program Management 2010-06-07 16:08:17 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 6 RHEL Product and Program Management 2010-07-15 14:46:11 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 8 RHEL Product and Program Management 2011-01-07 15:54:13 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 9 RHEL Product and Program Management 2011-02-01 05:58:41 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 10 RHEL Product and Program Management 2011-02-01 18:21:41 UTC
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Comment 14 RHEL Product and Program Management 2011-10-07 16:07:37 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 15 Jan Horak 2012-03-22 14:47:08 UTC
Can you reproduce this bug by any chance lately?

Comment 16 Matěj Cepl 2012-03-22 23:05:44 UTC
I haven't seen it lately (now on thunderbird-10.0.1-3.el6_2.x86_64)

Comment 17 Jan Horak 2012-03-26 11:37:43 UTC
It seems that this bug is not recurring lately. Closing as currentrelease.


Note You need to log in before you can comment on or make changes to this bug.