Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 593728 - a failure to start a single nanny kills off *all* running nannys
a failure to start a single nanny kills off *all* running nannys
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: piranha (Show other bugs)
6.0
i386 Linux
high Severity high
: rc
: ---
Assigned To: Marek Grac
Cluster QE
: OtherQA
Depends On: 505172
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-19 11:24 EDT by Marek Grac
Modified: 2018-11-14 05:46 EST (History)
9 users (show)

See Also:
Fixed In Version: piranha-0.8.5-8.el6
Doc Type: Bug Fix
Doc Text:
Previously, failure to start a single nanny daemon could terminate all the other nanny daemons. As a result, piranha could stop routing requests to real servers if one service monitor failed. This update adds a new option in the lvs.cf file, "hard_shutdown". The old behavior is retained with the default setting of 1. If a 0 value is set, a single nanny does not kill all nannies but the system needs manual intervention.
Story Points: ---
Clone Of: 505172
Environment:
Last Closed: 2011-12-06 12:57:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1716 normal SHIPPED_LIVE piranha bug fix update 2011-12-05 20:02:16 EST

  None (edit)
Comment 2 RHEL Product and Program Management 2010-05-19 11:35:33 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 11 Marek Grac 2011-07-08 05:26:03 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
New keyword for lvs.cf was added. 

hard_shutdows = (0 | 1) 

1 (default) => problem with single nanny will kill all nannies
0 => problem with single nanny won't kill all nannies but system needs manual intervention
Comment 18 Eliska Slobodova 2011-10-25 05:50:05 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,6 +1 @@
-New keyword for lvs.cf was added. 
+Previously, failure to start a single nanny daemon could terminate all the other nanny daemons. As a result, piranha could stop routing requests to real servers if one service monitor failed. This update adds a new option in the lvs.cf file, "hard_shutdown". The old behavior is retained with the default setting of 1. If a 0 value is set, a single nanny does not kill all nannies but the system needs manual intervention.-
-hard_shutdows = (0 | 1) 
-
-1 (default) => problem with single nanny will kill all nannies
-0 => problem with single nanny won't kill all nannies but system needs manual intervention
Comment 20 errata-xmlrpc 2011-12-06 12:57:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1716.html

Note You need to log in before you can comment on or make changes to this bug.