Bug 59390 - Old version pdfEtex in tetex-1.0.7-38.2 (RH7.2 update)
Old version pdfEtex in tetex-1.0.7-38.2 (RH7.2 update)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-06 16:13 EST by Joop Susan
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-25 12:05:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to build pdfetex from the 0.14h source (1.79 KB, patch)
2002-02-11 14:05 EST, Joop Susan
no flags Details | Diff
Add rule to top level makefile to build pdfetex (402 bytes, patch)
2002-02-11 14:08 EST, Joop Susan
no flags Details | Diff
ConTeXt source patch to spec-fdf.tex (bugfix for rounded frames. Version 2002.1.28) (674 bytes, patch)
2002-02-17 14:02 EST, Joop Susan
no flags Details | Diff
Patch to tetex.spec (tetex-1.0.7-40) that updates ConTeXt to a recent version. (2.38 KB, patch)
2002-02-17 14:06 EST, Joop Susan
no flags Details | Diff

  None (edit)
Description Joop Susan 2002-02-06 16:13:01 EST
Description of Problem:
Old version pdfEtex

Version-Release number of selected component (if applicable):
tetex-1.0.7-38.2 (RH7.2 update)

Although the pdftex binary has been updated, pdfEtex has not. This is a problem
 when using ConTeXt (also part of tetex).

How Reproducible:
Every time

Steps to Reproduce:
1. pdftex -version
2. pdfetex -version

Actual Results:
pdftex -version returns:
pdfTeX (Web2C 7.3.3.1) 3.14159-0.14h-released-20010417
kpathsea version 3.3.3.1

This is OK.

pdfetex -version returns:
pdfeTeX (Web2C 7.3.1) 3.14159-0.13d-2.1
kpathsea version 3.3.1

This is not! These two binaries seem to be from different source files, at     
least the pdfetex binary does not seem to be from pdftex-20010417.tgz.

Expected Results:
Expecting pdfetex -version to return:
pdfeTeX (Web2C 7.3.3.1) 3.14159-0.14h-released-20010417-2.1
kpathsea version 3.3.3.1

Additional Information:
In the SPEC file, instead of 'make pdftex' in the 'src/texk/web2c' directory, we
need 'make pdftex pdfetex'. The sources are already there, we just need to
create the binaries...

Side note: The latest beta releases of ConTeXt are more stable/usable  than the
ones included in tetex-1.0.7-38.2 (in texmf/tex/context), but need the same
release pdfetex as pdftex.
Comment 1 Tim Waugh 2002-02-06 17:17:34 EST
Have you verified that works when rebuilding the package?  I seem to recall
running into problems getting it to work, but perhaps my memory is wrong.

Can you point me to the latest ConTeXt that you think should be included as
well, so that I don't accidentally pick up an old one?

Thanks.
Comment 2 Joop Susan 2002-02-06 19:13:27 EST
Yes, if I do an 'rpm --rebuild', etc. The result is the same. That is is
reproducible, is obvious from the SPEC file. The pdftex update is IMHO a bit of
a hack. The pdftex binary is actually built twice. Once from the 'teTex-src'
(source0) archive + patches and once from (source26) 'pdftex-20010417.tgz'.

Source0 contains the old pdf(e)tex and both are built (courtesy line 441 of the
SPEC). Source26 contains the new pdf(e)tex (line 473). Pdftex is built and
installed (again), but not so pdfetex.

As stated before line 473 could easily change to
'make pdftex pdfetex' and the code around line 496 wants to install
'texk/web2c/pdfetex' as well.

I you would like, I could create a 'diff -u' for these changes and a seperate
one for the updated ConTeXt package.

At the moment ConTeXt lives at the temporary location:
http://ds035.xs4all.nl/context/beta/cont-tmf.zip
These 'beta' versions are very stable. The ConText authors (pragma@wxs.nl)
recommend to always use the latest beta. Support (by the authors) via the
mailinglist is excellent and fast. It is a good alternative to LaTeX.
Comment 3 Tim Waugh 2002-02-07 14:54:49 EST
> The pdftex update is IMHO a bit of a hack.

Yes, certainly.  Any suggestion for making it better?

With pdfetex: I get this:
make: *** No rule to make target `pdfetex'.  Stop.

I actually would appreciate a spec file diff, if you wouldn't mind.  Sorry..
Comment 4 Joop Susan 2002-02-11 14:05:51 EST
Created attachment 45300 [details]
Patch to build pdfetex from the 0.14h source
Comment 5 Joop Susan 2002-02-11 14:08:06 EST
Created attachment 45301 [details]
Add rule to top level makefile to build pdfetex
Comment 6 Tim Waugh 2002-02-11 14:14:57 EST
Great, thanks.
Comment 7 Joop Susan 2002-02-11 14:19:39 EST
We would really need a newer teTeX version. Unfortunately, I don't know much   
about other flavours of TeX to look into this myself...

Anyway, for now we can adapt the hack.

The patchfile for updating 'tetex.spec' is called 'tetex.spec-pdfetex.patch'.  
It requires one extra patch named 'pdftex-20010417-makefile.patch' to be in 
the RPM_SOURCE_DIR.

You were right when you said that 'make pdftex pdfetex' did not work. 
The top-level makefile only contains a rule for 'pdftex'. The makefile in 
src/texk/web2c however does contain a rule for 'pdfetex'. The appended 
'pdftex-20010417-makefile.patch' fixes this by adding the extra rule to 
the top-level makefile, delegating to the lower makefile like the 'pdftex' 
rule does.

I've tested the result and it seems to work well.

Regarding ConTeXt:

It may be better to remove ConTeXt from the tetex SRPM. ConTeXt is in active   
developement and it produces several new versions per year with bug fixes and  
new features (recent additions include XML-support for instance). It is a      
nuisance to compile the whole tetex package (due to it's size) every time that 
there is an update. It should not be too difficult to remove ConTeXt from the  
tetex SRPM an create a new separate ConTeXt SRPM (ConTeXt, ConTeXt-docs and    
ConTeXt-printdoc RPMs), so ConTeXt can be updated without conflicts with the   
tetex package. The ConTeXt RPMs will be dependent on this (ConTeXt stripped)   
version of tetex with it's updated 'pdftex' and 'pdfetex'.

I think that I will develop my personal tetex installation along this line.

It is possible to update ConTeXt within the tetex package.

Would RedHat be interrested in a patch to update ConTeXt to a more useful and  
stable version or rather a patch that splits ConTeXt off the tetex SRPM? The   
ConTeXt version in tetex-1.0.7-38.2 is 2000.1.31. The latest stable release is
2001.11.13. Beta versions are released about once a month (latest 2002.01.28).
Comment 8 Tim Waugh 2002-02-12 03:29:26 EST
I think just updating the ConTeXt in the teTeX package would be useful for the
short term.  Longer term it makes sense to split it out into a separate package.
Comment 9 Joop Susan 2002-02-12 11:43:53 EST
OK. For personal use I'm working on the tetex-context split first (which is
already 90% finished, it only needs testing now). It should not be difficult to
derive a patch for an update only. 

My new ConTeXt SRPM is rather big (22 Mb) with all included documentation.

12-Feb-02 00:54  1372    context-2001.1.28-0.1j.i386.rpm
12-Feb-02 00:54  3636    context-doc_screen_NL-2001.1.28-0.11j.i386.rpm
12-Feb-02 00:54  3272    context-doc_paper_NL-2001.1.28-0.11j.i386.rpm
12-Feb-02 00:55  6396    context-doc_screen_EN-2001.1.28-0.1j.i386.rpm
12-Feb-02 00:55  5800    context-doc_paper_EN-2001.1.28-0.1j.i386.rpm
12-Feb-02 00:55  2176    context-doc_EN-2001.1.28-0.1j.i386.rpm

The update patch will not include any extra documentation. It will increase the
size of the tetex package by 1.6 Mb (= size of the bare ConTeXt sources).

I'll try to get an update patch to you by the end of this weekend.
Comment 10 Tim Waugh 2002-02-13 09:10:42 EST
pdfetex updated in tetex-1.0.7-40 in rawhide (thanks!).

Leaving open for the ConteXt stuff.
Comment 11 Joop Susan 2002-02-13 13:57:20 EST
OK. I'm nearly ready to start on that ConTeXt update patch.

I have finished my tetex-context split patch. Just like jadetex my new
context RPMS are 'noarch'. Using an older "known stable" ConTeXt version in the
new SRPM (the version that I've used for the past 6 months) I have reprocessed
several documents that I produced last year (some 300 pages) and the result
looks identical. So that one seems to work. Including the pdfetex changes it's
only a 133 line unified diff against tetex.spec (1.0.7-38.2) to remove the old
context in order to prevent conflicts with the new ConTeXt RPMs.
I'll create an update diff on version 1.0.7-40 without extra documentation.
Comment 12 Joop Susan 2002-02-17 13:55:55 EST
Find attached two patches to update ConTeXt to a newer version. 

Download the ConTeXt source from:
http://www.pragma-pod.nl/context/beta/cont-tmf.zip
Please check that you have version 2002.1.28, otherwise the patch on the ConTeXt
source might not apply. It's awkward that the author does not put the version
number in the filename (It's only on the website). You can find the version
number in 'tex/context/base/context.tex' in the archive around line 18.

The first patch corrects a known-bug in this version of the ConTeXt source.

The second patch updates 'tetex.spec'. It removes the old sources, unpacks the
new archive and patches it. The Perl scripts are made executable and linked to
/usr/bin.
It's a hack, but it has been verified to work...
Comment 13 Joop Susan 2002-02-17 14:02:14 EST
Created attachment 45880 [details]
ConTeXt source patch to spec-fdf.tex (bugfix for rounded frames. Version 2002.1.28)
Comment 14 Joop Susan 2002-02-17 14:06:23 EST
Created attachment 45881 [details]
Patch to tetex.spec (tetex-1.0.7-40) that updates ConTeXt to a recent version.
Comment 15 Tim Waugh 2002-02-22 09:42:29 EST
ConTeXt updated in 1.0.7-42.  Thanks.

I'll close this as 'deferred' so that we can look at splitting the package out
next time.

Note You need to log in before you can comment on or make changes to this bug.