Bug 593958 - can't install gcc.x86_64 and gcc.i386 side-by-side
can't install gcc.x86_64 and gcc.i386 side-by-side
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.5
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: James Antill
BaseOS QE Security Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-20 03:05 EDT by mark cox
Modified: 2014-01-21 01:18 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-26 09:35:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mark cox 2010-05-20 03:05:30 EDT
Description of problem:
can't install gcc.x86_64 and gcc.i386 side-by-side

Version-Release number of selected component (if applicable):
$ yum --version
3.2.22
*Note* Red Hat Network repositories are not listed below. You must run this command as root to access RHN repositories.
  Installed: rpm-4.4.2.3-18.el5.x86_64 at 2009-10-28 23:56
  Built    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> at 2009-07-24 05:58
  Committed: Panu Matilainen <pmatilai@redhat.com> at 2009-07-24 22:00

  Installed: yum-3.2.22-26.el5.noarch at 2010-04-14 01:43
  Built    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> at 2010-02-23 16:50
  Committed: James Antill <jantill@redhat.com> at 2010-02-23 22:00

  Installed: yum-metadata-parser-1.1.2-3.el5.x86_64 at 2009-10-29 00:53
  Built    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> at 2009-04-06 14:15
  Committed: James Antill <james.antill@redhat.com> at 2009-04-06 22:00

  Installed: yum-rhn-plugin-0.5.4-15.el5.noarch at 2010-05-17 02:41
  Built    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> at 2009-12-21 11:59
  Committed: Milan Zazrivec <mzazrivec@redhat.com> at 2009-12-21 22:00

How reproducible:
Every time. 

Steps to Reproduce:
1. sudo yum install gcc.i386

2.
3.
  
Actual results:


markcox@devbuild:/home/markcox/cvs/util_make:)
$ sudo yum update
Loaded plugins: protectbase, rhnplugin, security
redhat-cache                                                                                                                                                                  |  951 B     00:00
redhat-i386-cache                                                                                                                                                             |  951 B     00:00
rpmforge-cache                                                                                                                                                                |  951 B     00:00
rpmforge-i386-cache                                                                                                                                                           |  951 B     00:00
9888 packages excluded due to repository protections
Skipping security plugin, no data
Setting up Update Process
No Packages marked for Update

markcox@devbuild:/home/markcox/cvs/util_make:)
$ sudo yum install gcc.i386
Loaded plugins: protectbase, rhnplugin, security
9888 packages excluded due to repository protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package gcc.i386 0:4.1.2-44.el5 set to be updated
--> Processing Dependency: cpp = 4.1.2-44.el5 for package: gcc
--> Running transaction check
---> Package cpp.i386 0:4.1.2-44.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=====================================================================================================================================================================================================
 Package                                  Arch                                      Version                                             Repository                                              Size
=====================================================================================================================================================================================================
Installing:
 gcc                                      i386                                      4.1.2-44.el5                                        redhat-i386-cache                                      5.2 M
Installing for dependencies:
 cpp                                      i386                                      4.1.2-44.el5                                        redhat-i386-cache                                      2.7 M

Transaction Summary
=====================================================================================================================================================================================================
Install       2 Package(s)
Upgrade       0 Package(s)

Total download size: 7.9 M
Is this ok [y/N]: y
Downloading Packages:
(1/2): cpp-4.1.2-44.el5.i386.rpm                                                                                                                                              | 2.7 MB     00:00
(2/2): gcc-4.1.2-44.el5.i386.rpm                                                                                                                                              | 5.2 MB     00:00
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                                 22 MB/s | 7.9 MB     00:00
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
gcc is needed by (installed) gcc-c++-4.1.2-48.el5.x86_64
gcc is needed by (installed) gcc-java-4.1.2-48.el5.x86_64
gcc is needed by (installed) libmudflap-devel-4.1.2-48.el5.x86_64
gcc is needed by (installed) gcc-c++-4.1.2-48.el5.x86_64
gcc is needed by (installed) gcc-java-4.1.2-48.el5.x86_64
gcc is needed by (installed) libmudflap-devel-4.1.2-48.el5.x86_64
Complete!
(1, [u'Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%205&component=yum'])

markcox@devbuild:/home/markcox/cvs/util_make:(
$


Expected results:


Additional info:
Comment 1 seth vidal 2010-05-20 08:38:34 EDT
Can you run:

package-cleanup --problems

and report the output?
Comment 2 James Antill 2010-05-20 09:26:27 EDT
What does:

package-cleanup --problems

...say?
 And then:

yum list gcc\*

...I'm somewhat confused because as far as I can see "gcc" itself is not multilib. ... and thus. yum shouldn't have access to gcc.x86_64 and gcc.i386.
Comment 3 mark cox 2010-05-25 22:47:43 EDT
James, I had the i386 and x86_64 repositories enabled. when i removed i386 repositories, gcc.i386 was not available, i will have to investigate a different method to build i386 binaries.
thanks.
Comment 4 James Antill 2010-05-26 09:35:11 EDT
Right, I wondered if you'd done that ... the problem is that packages need work to be multilib. ... much more so than just enabling the i386 repos.
Within the x86_64 repo. are all the packages RHEL supports as multilib. ... in theory you can request more packages in this set (but I kind of doubt gcc would be approved, esp. at this point in RHEL-5).

Note You need to log in before you can comment on or make changes to this bug.