Bug 593984 - [UEFI] anaconda creates new efi system partition even if one already exists.
Summary: [UEFI] anaconda creates new efi system partition even if one already exists.
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 6.0
Hardware: x86_64 Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Peter Jones
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 582286 647893
TreeView+ depends on / blocked
 
Reported: 2010-05-20 09:08 UTC by Pavel Holica
Modified: 2011-05-19 12:29 UTC (History)
5 users (show)

Fixed In Version: anaconda-13.21.88-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 12:29:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0530 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2011-05-18 17:44:52 UTC

Description Pavel Holica 2010-05-20 09:08:08 UTC
Description of problem:
Doing multiple UEFI installations on same machine (using "Replace Existing Linux System(s)") causes, that there are more "efi system partition"s and several entries in UEFI menu, which are working from UEFI's point of view. However, they don't work, because grub inside has configuration which points to next partition, which is another "efi system partiton".

Eg.
First installation:
/dev/sda1 - /boot/efi (efi system partition) (grub pointing to /dev/sda2)
/dev/sda2 - /boot (ext4)
/dev/sda3 - / (ext4)

Second installation:
/dev/sda1 - (efi system partition) (grub pointing to /dev/sda2)
/dev/sda2 - /boot/efi (efi system partition) (grub pointing to /dev/sda3)
/dev/sda3 - /boot (ext4)
/dev/sda4 - / (ext4)

Third installation:
/dev/sda1 - (efi system partition) (grub pointing to /dev/sda2)
/dev/sda2 - (efi system partition) (grub pointing to /dev/sda3)
/dev/sda3 - /boot/efi (efi system partition) (grub pointing to /dev/sda4)
/dev/sda4 - /boot (ext4)
/dev/sda5 - / (ext4)

Version-Release number of selected component (if applicable):
RHEL6.0-20100512.0 x86_64 Server

How reproducible:
always

Steps to Reproduce:
1. Install UEFI RHEL6
2. Install UEFI RHEL6 again using "Replace Existing Linux System(s)" option
  
Actual results:
There are more "efi system partition"s and only the last one works.

Expected results:
There should be only one "efi system partition" all time.

Additional info:
Please note, that RHEL is not the only one system supporting UEFI, and that this partition may be used by other operating systems (other distributions or other non-Linux systems).

Comment 1 RHEL Product and Program Management 2010-05-20 09:25:22 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 Pavel Holica 2010-06-30 10:03:51 UTC
Hello,
what is the situation of fix for this bug please?

Comment 9 Martin Sivák 2011-01-18 13:08:29 UTC
This fix will be included in anaconda-13.21.88-1.

Comment 11 Pavel Holica 2011-03-02 12:11:30 UTC
Verified fix on RHEL6.1-20110224.2 x86_64 ComputeNode.

Comment 12 errata-xmlrpc 2011-05-19 12:29:33 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0530.html


Note You need to log in before you can comment on or make changes to this bug.